[Owncloud] Fwd: ownCloud 4.5 beta 4

Bjoern Schiessle schiessle at owncloud.com
Fri Sep 21 13:15:45 UTC 2012

On Fri, 21 Sep 2012 13:00:07 +0100 Duarte Velez Grilo wrote:
> I just checked the permissions, and they are like yours. I started 
> looking at the code, and I think the error happens in 
> /home/[username]/[owncloud_domain.com]/apps/files_external/lib/webdav.php, 
> on line 129, function fopen. I tried to find out how to execute this 
> from the command line, but Google wasn't able to help me. Does anyone 
> know how to execute a function from a php file, using the CLI?

You can use curl from the command line (curl https://www.box.com
--cacert /path/to/rootcerts.cert). You can also try it without a cacert
path, but this only works if the certs are installed system wide.

But your error code (77) appears exactly in one case: If the file you
point to is not readable by curl. You would already get a different
error if the path to the cert file would be wrong.

Even if I don't know why this should be necessary, but have you tried to
give broader rights to the file and to the directories above?

That the error appears in fopen() is only, because that's the first
function called to access the webdav server. Looking at the error I
don't think that there is a bug in fopen.


Björn Schießle <schiessle at owncloud.com>
Software Developer
ownCloud GmbH

Your Data, Your Cloud, Your Way!

ownCloud GmbH, GF: Markus Rex, Holger Dyroff
Schloßäckerstrasse 26a, 90443 Nürnberg, HRB 28050 (AG Nürnberg)

More information about the Owncloud mailing list