[Owncloud] Fwd: ownCloud 4.5 beta 4

Duarte Velez Grilo duartegrilo at gmail.com
Thu Sep 20 17:18:24 UTC 2012

Em 20-09-2012 17:10, Bjoern Schiessle escreveu:
> On Thu, 20 Sep 2012 16:22:02 +0100 Duarte Velez Grilo wrote:
>> Thank you. I think we're getting there, but it's still not working.
>> This is what I did:
>> - I'm using Dreamhost, so I don't have root access.
>> - Using the browser, as you suggested, I found the ones being used by
>> Dropbox and Box (thawte_Primary_Root_CA.cer and
>> GeoTrust_Global_CA.pem, respectively)
>> - I uploaded them via the owncloud's personal settings page
>> - I then tried opening the mount point directories, but still got the
>> errors:
> Did you were able to authenticate ownCloud against dropbox in the
> settings.
> I'm asking because I removed my system wide certificates for testing.
> Without the certificates I even wasn't able to set up the dropbox
> mount. Whenever I clicked the "grant access" button I got this error
> dialogue: "Fetching request tokens failed. Verify that your Dropbox app
> key and secret are correct." So I wonder how you could set up the mount
> point at all without the right certificates.
> Beside that it looks like for Dropbox the certificates uploaded to
> ownCloud aren't used. At the moment I'm not sure if this is a
> certificate issue at all if you where able to set up the dropbox mount..
> Maybe someone who implemented the dropbox mount can have a look at it.

I had no problems granting access to owncloud when I did it. Anyway, I 
removed the mount from owncloud and added it again, now with the 
certificates already there. Again, no problems granting access. But 
still no go. At least the error changed: 
{"app":"files_external","message":"Error: (503) SERVICE 

>> (for box.com) {"app":"webdav client","message":"[CURL] Error while
>> making request: error setting certificate verify locations:\n  CAfile:
>> \/home\/[username]\/[owncloud_domain.com]\/data\/[username]\/files_external\/rootcerts.crt\n
>>   CApath: \/etc\/ssl\/certs\n (error code:
>> 77)","level":3,"time":1348153736}
> But this really looks like a problem with the imported rootcerts. Is
> the path to rootcerts.crt correct?

Does the file exists and contain the
> uploaded certificates?
I never tried box.com before but I will have a
> look at it and come back to you if I know more.

Indeed, I looked up CURL error 77 
(http://curl.haxx.se/libcurl/c/libcurl-errors.html) and it says: 

Problem with reading the SSL CA cert (path? access rights?)

I also removed and added again this mount, but the error remains the same.


More information about the Owncloud mailing list