[Owncloud] Need help to run owncloud on FreeBSD

Roland van Laar roland at micite.net
Sun Apr 1 19:16:56 UTC 2012

On 04/01/2012 04:42 PM, Martyn Hill wrote:
> Dear list
> I have tried several times to configure owncloud (v2 and v3) on my 
> FreeBSD server at home, but always get stuck at the very same point.
> I should like some guidance on how to troubleshoot the process, if 
> anyone here can assist. I can't find my specific problem in any of the 
> existing forum/mail postings...
> In simple terms, having installed owncloud either from FreeBSD ports 
> or 'manually' from the binary and GIT repository, I am able to access 
> the first config page where the admin credentials are requested and 
> type of DB backend, I click submit and then... nothing.
> I have also tried different browsers (IE 7, 8, Google Crome, Firefox) 
> in case it was a client issue.
> Always the same observed result, whether SQLIte or MySQL (after first 
> configuring the MySQL user) is chosen.
> My environment:
>     FreeBSD 8.1 RELEASE
>     Apache 2.2
>     SQLite 3.7.9 & MySQL 5.1
> <All the php modules listed on the owncloud requisites page - v5.3.8)>
> My first question is: /*How do you debug the php scripts that are run?*/
Me Too :).
I have the same problem using FreeBSD, although I'm running it inside a 
I'm tried using both apache and nginx with php-fpm.

You can use Xdebug:  http://xdebug.org/index.php

> The closest I've gotten to tracking down the problem is somewhere in 
> the MDB2/Driver sections, but that was a somewhat blind goose-chase 
> through the php code, trying to run each script in the chain one at a 
> time.

I'm in the process of installing Xdebug.
The call 3rdparty/MDB2/Schema.php:399 $result = $parser->parse();
doesn't return. There is no output after this step.
> Any ideas? I've read of others who are succesfully running OC on 
> FreeBSD, or at least getting beyond this very first hurdle.

After installing owncloud 2 from ports in a regular FreeBSD installation 
and copying in the new owncloud.
I see the redirect to files/index.php after the initial installation and 
the following error happens.
Fatal error: Call to undefined method MDB2_Statement_sqlite::fetchRow() 
in /usr/local/www/owncloud/lib/app.php on line 108


Roland van Laar
> Regards,
> Martyn Hill
> London.
> -- 
> "There are 10 types of people in this world. Those who understand binary and those who don't."
> This body part will be downloaded on demand.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/owncloud/attachments/20120401/04f4a0d9/attachment.html>

More information about the Owncloud mailing list