[Nepomuk] Review Request 108811: Change dbus interface to the FileIndexer for status messages

Vishesh Handa me at vhanda.in
Wed Feb 13 15:13:40 UTC 2013


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/108811/#review27377
-----------------------------------------------------------



services/fileindexer/fileindexer.h
<http://git.reviewboard.kde.org/r/108811/#comment20605>

    I'm okay with throwing this away. As far as I know we offer no guarantee that the dbus interface will not change.
    
    I think we will need to keep userStatusString cause the nepomuk controller still uses it. Or we could just update that, and then throw away userStatusString as well.



services/fileindexer/fileindexer.h
<http://git.reviewboard.kde.org/r/108811/#comment20602>

    Typo! :)



services/fileindexer/fileindexer.h
<http://git.reviewboard.kde.org/r/108811/#comment20604>

    Please rename to emitStatusMessage



services/fileindexer/indexscheduler.cpp
<http://git.reviewboard.kde.org/r/108811/#comment20603>

    I would prefer if you just returned the internal State variable. That seems to give the status rather nicely?
    
    It even has a State_Cleaning
    
    This translation to an integer can be done in the FileIndexer class.


- Vishesh Handa


On Feb. 6, 2013, 4:42 p.m., Jörg Ehrichs wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/108811/
> -----------------------------------------------------------
> 
> (Updated Feb. 6, 2013, 4:42 p.m.)
> 
> 
> Review request for Nepomuk and Vishesh Handa.
> 
> 
> Description
> -------
> 
> To have a unified dbus interface this patch adds the signal:
> * statusMessage(int, string)
> and the method:
> * statusMessage
>     
> To expose the current state of the fileindexer via dbus.
> This change results in the same dbus signal/slot that are used by
> akonadi_nepomuk and the FileWatcher.
>     
> The integers are defined as
> status -1: suspended
> status  0: idle
> status  1: working (processing/searching for files to process)
> status  2: cleaning
> 
> Therefore the following method s are marked deprecated:
> * userStatusString - bad naming, same as statusMessage
> * simpleUserStatusString - not used/returns the same as userStatusString
> 
> 
> Diffs
> -----
> 
>   interfaces/org.kde.nepomuk.FileIndexer.xml 752604b 
>   services/fileindexer/fileindexer.h afe78d7 
>   services/fileindexer/fileindexer.cpp 3ddc073 
>   services/fileindexer/indexscheduler.h d53e7c9 
>   services/fileindexer/indexscheduler.cpp ef848e2 
> 
> Diff: http://git.reviewboard.kde.org/r/108811/diff/
> 
> 
> Testing
> -------
> 
> * Connected to the status signal via qdbusviewer
> * moved files around/added new folders for the indexing.
> * output shows current operation + url
> 
> 
> Thanks,
> 
> Jörg Ehrichs
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/nepomuk/attachments/20130213/77f992ab/attachment.html>


More information about the Nepomuk mailing list