[Nepomuk] Review Request: Allow synchronous execution of queries

Sebastian Trueg sebastian at trueg.de
Tue Jun 19 04:46:27 UTC 2012


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/105287/#review14872
-----------------------------------------------------------



libnepomukcore/query/query.h
<http://git.reviewboard.kde.org/r/105287/#comment11682>

    While I like the approach of calling execute directly on the query it does not match the design of the rest of the system. So far Query is a simple stand-alone container. To keep it that way it would be better to either have a method in the Nepomuk namespace or make the ResultIterator into something like:
    
    class QueryIterator {
    public:
    QueryIterator(const Query&);
    ...
    }



libnepomukcore/query/resultiterator.h
<http://git.reviewboard.kde.org/r/105287/#comment11683>

    I think QueryIterator would be a better name.



libnepomukcore/query/resultiterator.h
<http://git.reviewboard.kde.org/r/105287/#comment11684>

    I think thanks to additionalBindings the reqpropmap is rather deprecated.


- Sebastian Trueg


On June 18, 2012, 12:47 a.m., Vishesh Handa wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/105287/
> -----------------------------------------------------------
> 
> (Updated June 18, 2012, 12:47 a.m.)
> 
> 
> Review request for Nepomuk.
> 
> 
> Description
> -------
> 
> Allow synchronous execution of queries
> 
> This is done by returning a Nepomuk::Query::ResultIterator, and
> allows the user to control the execution of the query with the
> iterator.
> 
> This lets us move away from Soprano. Plus, this avoids
> code duplication as this code is being duplicated in both the
> query service and the kioslave.
> 
> 
> Diffs
> -----
> 
>   includes/Query/ResultIterator PRE-CREATION 
>   libnepomukcore/CMakeLists.txt 066c8986dfa2b3150072dbd96a71caf8873cea06 
>   libnepomukcore/query/query.h f4360b09fbc72bedcda5623e65d9e82359b66619 
>   libnepomukcore/query/query.cpp d67b6ce4cbbf5f30b468d9fd5b3399db1e3afd8c 
>   libnepomukcore/query/resultiterator.h PRE-CREATION 
>   libnepomukcore/query/resultiterator.cpp PRE-CREATION 
> 
> Diff: http://git.reviewboard.kde.org/r/105287/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Vishesh Handa
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/nepomuk/attachments/20120619/6fea2abd/attachment.html>


More information about the Nepomuk mailing list