[Marble-devel] Review Request 124834: Better zoom with the mouse wheel for the Openstreetmap map theme and added a new empty map theme for OSM file loading.

Dávid Kolozsvári freedawson at gmail.com
Thu Aug 20 18:45:11 UTC 2015



> On Aug. 20, 2015, 6:03 p.m., Dennis Nienhüser wrote:
> > File Attachment: empty.dgml - empty.dgml
> > <https://git.reviewboard.kde.org/r/124834/#fcomment432>
> >
> >     I'd go for a higher maximum zoom than `<maximum>3500</maximum>`

I was thinking about it too, but there is a big performance drop after cca. 3600. Zomming in to maximum 3750 I barely could move the map(in release mode). Initially I tried with 4000, but that's not going to work. I'd say that 3600 is the max.


> On Aug. 20, 2015, 6:03 p.m., Dennis Nienhüser wrote:
> > File Attachment: empty-preview.png - empty-preview.png
> > <https://git.reviewboard.kde.org/r/124834/#fcomment433>
> >
> >     we have a tool in tools/maptheme-previewimage/ to generate map theme preview images automatically. I uploaded its result to http://nienhueser.de/marble/empty-preview.png
> 
> Torsten Rahn wrote:
>     This doesn't look consistent with the other icons: 
>     
>     - the padding (space between circle and black square) should be bigger (about twice the current size)
>     - there needs to be a visible drop shadow

Ouh, didn't know that. Where can I find it? :)
I created mine in Krita based on the OpenStreetmap's preview image.


> On Aug. 20, 2015, 6:03 p.m., Dennis Nienhüser wrote:
> > src/lib/marble/MarbleAbstractPresenter.cpp, line 261
> > <https://git.reviewboard.kde.org/r/124834/diff/1/?file=396571#file396571line261>
> >
> >     `radiusVal = qBound( radius(minimumZoom(), radiusVal, radius(maximumZoom() );` is more readable

This is how it is used in `MarbleAbstractPresenter::zoomIn()` and `MarbleAbstractPresenter::zoomOut()`. Should I change it in those too?


> On Aug. 20, 2015, 6:03 p.m., Dennis Nienhüser wrote:
> > data/CMakeLists.txt, line 209
> > <https://git.reviewboard.kde.org/r/124834/diff/1/?file=396569#file396569line209>
> >
> >     Since it is mostly useful only for developers I wouldn't want it to show up for users. The easiest way to accomplish that is to restrict its installment by a new cmake option called e.g. 'MARBLE_EMPTY_MAPTHEME' that defaults to OFF.

Well, I thought that it would be useful for the users too, especially if we implement the fine zoom for the OpenStreetmap theme, then there won't be any other map theme where the user could load and view osm files freely, without restrictions to zoom level. Especially if they want to edit the map, it is usefull to have a simple background. In my opinion :)


- Dávid


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/124834/#review84098
-----------------------------------------------------------


On Aug. 20, 2015, 4:54 a.m., Dávid Kolozsvári wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/124834/
> -----------------------------------------------------------
> 
> (Updated Aug. 20, 2015, 4:54 a.m.)
> 
> 
> Review request for Marble.
> 
> 
> Repository: marble
> 
> 
> Description
> -------
> 
> * There is a `zoomAt()` and a `zoomBy()` method in `MarbleAbstractPresenter`, so I've created a new `void MarbleAbstractPresenter::zoomAtBy(const QPoint &pos, int zoomStep)` method to combine the functionality of both. This new method is used in `MarbleDefaultInputHandler::handleWheel()`, but only if the map theme is `Openstreetmap`.
> * The new `Empty` map theme is a simple 50 line .dgml file, with just a single empty geodata layer. Calling it `Empty` is a good idea or should we use another name for it?
> 
> 
> Diffs
> -----
> 
>   data/CMakeLists.txt 0a9c6e5 
>   src/lib/marble/MarbleAbstractPresenter.h 7fb203d 
>   src/lib/marble/MarbleAbstractPresenter.cpp acaab22 
>   src/lib/marble/MarbleInputHandler.cpp 393ce42 
> 
> Diff: https://git.reviewboard.kde.org/r/124834/diff/
> 
> 
> Testing
> -------
> 
> A small video demonstrating these two new features:
> https://www.youtube.com/watch?v=jMorQDwr2A8
> 
> 
> File Attachments
> ----------------
> 
> empty-preview.png
>   https://git.reviewboard.kde.org/media/uploaded/files/2015/08/20/132190ff-11f7-45a2-b361-266f6aa752fc__empty-preview.png
> empty.dgml
>   https://git.reviewboard.kde.org/media/uploaded/files/2015/08/20/39c98dcb-b35f-421a-bcf9-c3f95f15cfe3__empty.dgml
> 
> 
> Thanks,
> 
> Dávid Kolozsvári
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/marble-devel/attachments/20150820/620b8d3a/attachment.html>


More information about the Marble-devel mailing list