D17971: Revive External Tools plugin

gregormi noreply at phabricator.kde.org
Sun Feb 3 17:40:14 GMT 2019

gregormi added a comment.

  I tried the plugin, these are my observations:
  - From the "Edit Tool" GUI I found no help which **variables** can be used.
  - I used this command: bash with arguments: -c "echo %{filename}"
    - Output "Display in Pane": **has no effect**
    - Output "Insert in New Document": works fine
    - Output "Append to Current Document": works fine
    - Output "Replace Current Document": works fine
    - Output "Replace Selected Text": works fine
    - Output "Insert at Cursor Position": works fine, even if text is selected
  - The file **externaltools** contains a number of tools. As I understand those should be made available under a "Add Preset" or "Add Template" button but are not visible by default which requires an initial user action, right? Thoughts about this:
    - Make these tools **available by default** in their respective category.
    - In the settings page those tools appear with a postfix, e.g. "Run Shell Script [built-in]"
    - If the user needs to change one: either let him edit the built-in item with a reset button or let him copy the original item with the possibility to disable it
  - Is there a way to copy an existing tool? Can it be exported to be shared (ideally in the ini format of the externaltools file so that tested tools can be easily made available there)?
  - I tried to add this tool, working example: `git gui blame -- README.md`. Edit Tool: Executable: `git`, Arguments: `gui blame -- %{filename}`. The gui gui starts but not with the selected file to blame. When I set Working Directory to %{directory}, then it works which means the default setting "Use current document path if empty" does not work properly.
  - %{directory} expands to e.g. `///home/gregor/kde/src/kde/applications/kate/` Are the three slashes intended?

  R40 Kate


To: dhaumann, cullmann, gregormi
Cc: brauch, pino, ngraham, kwrite-devel, hase, michaelh, demsking, cullmann, sars, dhaumann
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kwrite-devel/attachments/20190203/29c058be/attachment.html>

More information about the KWrite-Devel mailing list