[Kstars-devel] I'm missing something for new UI file handling

Jason Harris kstars at 30doradus.org
Thu Apr 13 07:27:33 CEST 2006


Hello,

Okay, sorry for my earlier confusion...real forehead-smack moment there.  I 
seem to have figured out how to get ui-generated headers working, but I have 
one remaining problem.

The generated header files are wrapped in an #ifndef statement, but I have a 
problem with the naming scheme it uses for the variable.  I have a UI file 
named "locationdialog.ui".  The generated header is "ui_locationdialog.h", 
and my derived class is declared in "locationdialog.h".  Now, logically, I 
would use "#ifndef LOCATIONDIALOG_H" as a wrapper in my own header file, but 
that's the variable name used in ui_locationdialog.h!  Shouldn't that file 
use UI_LOCATIONDIALOG_H ?

It took me a while to figure out why the compiler kept saying that "Ui" isn't 
a namespace: because the entire ui_locationdialog.h file is skipped due to 
the repeated ifndef variable!

Maybe not a big deal; the cheap answer is to tell me to just rename all of my 
ifndef constants.  But doesn't it make sense to have them match the filename?  

How are other people handling this?

thanks for your continued indulgence,
Jason

-- 
KStars: http://edu.kde.org/kstars
Community Forums: http://kstars.30doradus.org


More information about the Kstars-devel mailing list