Build on raspbian stretch

Thomas Steiger steigerth at
Sun Feb 10 20:26:49 GMT 2019

Dear community,

I try to build kst-plot for a raspberry pi. I use the latest raspbian OS. I
need to build from source, because I need python support (pykst).

A tried different ways (with qtcreator and with cmake) to build kst-plot
but unfortunately without success.

As explained in one of the last emails (
in this list, I did the following:
apt --assume-yes install build-essential
apt --assume-yes install cmake

apt --assume-yes install pkg-config

# gsl-bin not sufficient!
apt --assume-yes install libgsl-dev

apt --assume-yes install qtcreator
apt --assume-yes install qt5-default

# Asterisk is important - dev version needed
apt --assume-yes install libqt5svg5*

# Optional datasource libraries

# Can't find anything to make cmake happy
# The following didn't work
#apt --assume-yes install netcdf*
#apt --assume-yes install libnetcdf*

apt --assume-yes install libcfitsio-dev
apt --assume-yes install libgetdata-dev
apt --assume-yes install libtiff-dev
apt --assume-yes install libmatio-dev

git clone https://<yourGithubId>
cmake -Dkst_qt5=1 -Dkst_release=1 -Dkst_merge_files=1 ../kst
make -j 4

That leads to the following error:
In member function ‘bool DirFileSource::init()’:
error: ‘SindirEntryType’ was not declared in this scope
     const char **nl = _dirfile->FieldListByType(SindirEntryType);
In member function ‘int DirFileSource::readSindir(QString&, const QString&,
error: no matching function for call to ‘GetData::Dirfile::GetData(const
char*, int&, int, int, int, const char* [1])’
   _dirfile->GetData(field.toUtf8().constData(), frame, 0, 0, 1, tmpstr);
In file included from
/usr/include/getdata/dirfile.h:148:14: note: candidate: size_t
GetData::Dirfile::GetData(const char*, gd_off64_t, gd_off64_t, size_t,
size_t, GetData::DataType, void*) const
       size_t GetData(const char *field_code, gd_off64_t first_frame,
/usr/include/getdata/dirfile.h:148:14: note:   candidate expects 7
arguments, 6 provided
[ 59%] Building CXX object
die Regel für Ziel
make[2]: ***
Fehler 1
CMakeFiles/Makefile2:637: die Regel für Ziel
make[1]: ***
[src/datasources/CMakeFiles/kst2_datasource_dirfilesource.dir/all] Fehler 2
make[1]: *** Es wird auf noch nicht beendete Prozesse gewartet...
[ 59%] Building CXX object
[ 59%] Linking CXX shared module
[ 60%] Linking CXX shared module
[ 60%] Built target kst2_datasource_fitsimage
[ 60%] Built target kst2_datasource_matlab
Makefile:149: die Regel für Ziel „all“ scheiterte
make: *** [all] Fehler 2

The same error occured, when I build with qtcreator.

Can anybody tell me, how I can fix the problem? I would highly appreciate
any help. I like kst-plot very much!

Best regards,
Thomas Steiger
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Kst mailing list