[Kst] Re: link step failing with qmake

Nadine Leenders nadine at ualberta.ca
Wed May 18 19:42:27 CEST 2011

Hi Nicolas,

Thanks for your assistance!

On 2011-05-18, at 12:34 AM, Brisset, Nicolas wrote:

> Dear Nadine,
> it seems you are doing all this from the command line. I don't know if
> you can install qtcreator on that machine, but I'd definitely recommend
> doing this.

To install this, I've put in cmake, qmake, and qtcreator and have been going in circles trying to make it work.  Settled on qmake because I was making the best progress with it.  With, qtcreator, I get into it, and am clueless.

> It makes a lot of things easier, compiling among others. I
> don't know if you only want to use kst or also plan to be developing
> some stuff around it, but if you also want to be able to develop then
> really consider installing qtcreator.
> The other point is that we're slowly moving away from qmake and using
> cmake instead, which is now the recommended build system. Qmake should
> still work at this point, though.
> So let us know if qtcreator is an option, and if yes just open
> [source_root]/kst.pro (qmake) or [source_root]/cmake/CMakeLists.txt
> (cmake) file from the File->Open menu and let the tool guide you. If you
> have more than one Qt installation on your machine, you may want to set
> it in the Settings to make sure the right one gets picked up.

I went back to qtcreator and, I think, did as you said.  I did this as root, and it created /home/synth/sandbox/kst etc (a rather strange default).  In qtcreator, under Tools/Options/Qt4, it has for both auto-detected and manual, the version of Qt I want it to use; /usr/local/Trolltech/QT-4.7.3/bin/qmake .  It bothers me that there is no place to put where the includes are for QT-4.7.3, since there is another qt version on this system.

I tried doing build and am back to my original problem, I have the error message:
/usr/local/lib/libnetcdff_c++.a(netcdf.o): relocation R_X86_64_32S against `vtable for NcTypedComponent' can not be used when making a shared object; recompile with -fPIC
could not read symbols: Bad value
collect2: ld returned 1 exit status

With qmake I was able to get rid of the message by putting "staticlib" as an option to CONFIG in kst.pri .  I tried putting it back there and it seems that  qtcreator doesn't use this file.

More suggestions?

 - Nadine

More information about the Kst mailing list