[Kst] Open a file fails because widget only accepts directories

Brisset, Nicolas Nicolas.Brisset at eurocopter.com
Thu Jan 21 08:30:45 CET 2010

Hi Svenn,

funnily, I sometimes run into the problem as well. Right now, I have a beta4 build where I see the problem when I set my QTDIR to a Qt 4.5.1 installation, and when I switch it to a Qt 4.5.3 version (only changing QTDIR, PATH and LD_LIBRARY_PATH) it starts working. 
That looks like a Qt bug. Which version are you using? Have you tried a newer one? 

Best regards,



Eurocopter Deutschland GmbH
Sitz der Gesellschaft/Registered Office: Donauwoerth
Registergericht/Registration Court: Amtsgericht Augsburg HRB 16508
Vorsitzender des Aufsichtsrates/Chairman of the Supervisory Board: Dr. Lutz Bertling
Geschaeftsfuehrung/Board of Management:
Dr. Wolfgang Schoder, Vorsitzender/CEO; Friedrich-Wilhelm Hormel; Ralf Barnscheidt


This communication and the information it contains is intended for the addressee(s) named above and for no other persons or organizations. It is confidential and may be legally privileged and protected by law. The unauthorized use, copying or disclosure of this communication or any part of it is prohibited and may be unlawful. 
If you have received this communication in error, kindly notify us by return e-mail and discard and/or delete the communication. Thank you very much. 
It is possible for e-mails to be intercepted or affected by viruses. Whilst we maintain virus checks on our e-mails, we accept no liability for viruses or other material which might be introduced with this message. 
-----Ursprüngliche Nachricht-----
> Von: Svenn Are Bjerkem [mailto:svenn.bjerkem at googlemail.com]
> Gesendet: Mittwoch, 20. Januar 2010 16:51
> An: kst at kde.org
> Betreff: [Kst] Open a file fails because widget only accepts directories
> Hi,
> I have compiled svn 1077649 of the qt4 port, and have the problem that
> opening files give me a widget that only accepts directories. I can't
> select a csv file with the data wizard.
> Opening .kst files give me nothing in data manager.
> I first installed the version available for openSUSE and also saw this
> problem, so I decided to compile my own version. I then discovered
> that the directory browser widget came up in the same directory as the
> pre-compiled version. I am looking for any configure files for kst
> that I maybe need to delete.
> I also see that I have to set LD_LIBRARY_PATH to /usr/local/lib64 to
> get kst2 to run. (same with precompiled binary for openSUSE)
> Any help?
> Kind regards,
> --
> Svenn
> _______________________________________________
> Kst mailing list
> Kst at kde.org
> https://mail.kde.org/mailman/listinfo/kst

More information about the Kst mailing list