[Kst] Re: I need some help

nicolas.brisset at free.fr nicolas.brisset at free.fr
Thu Dec 23 13:37:40 CET 2010

Dear Khuong Huynh, 

if you're not experienced with programming you may want to download ready-made packages. You can find some information on the website: http://kst-plot.kde.org/download/binary_packages.php. 
For Windows you should find all that you need. It seems you are on Windows, since you mention dlls in your mail. In that case I'd definitely recommend downloading a ready-made package for a start. For Linux distributions, it may be more difficult to find the latest packages, but if you tell us what distribution you are using we may provide some help. 

Using QtCreator is of course also an option, and provides the added benefit that you can get the latest version any time or apply patches without having to wait for the next release. From the information you provide, I see 2 possible issues: 
1) it seems you have not properly instructed QtCreator that the executable you're interested in is kst, not d2asc. Changing that should be easy, but as it depends on the version of QtCreator you are using I can't provide more specific help at that point. Maybe you have even figured it out already, as you seem to have tried running kst as well. 
2) the libraries are built into a non-standard path (in your case E:\st-build-desktop\build\lib ), which is not in the paths where the system looks for dlls. In my case, I have added that directory to the environment variables in QtCreator (in the "Executaion Environment" section, variable named LD_LIBRARY_PATH) 

I hope that helps, 

Best regards, 


> Dear authors, 
> I am a international PhD student in Physics at Japan. I have tried to install the kst-plot using the Qt creator bundle but I got the message: 
> QCoreApplication::applicationDirPath: Please instantiate the QApplication object first 

QCoreApplication::applicationDirPath: Please instantiate the QApplication object first 

E:\kst-build-desktop\build\bin\d2asc.exe exited with code -1 
> from the Qt creator. When I tried to run kst.exe, it announced that the kst2lib.dll file is missing. 
> Could you help me to understand what is happening and how to fix it? I am a dummy in programing and I do not understand what is going on. 
> Thank you very much in advanced. 
> Best regards, 
> Khuong, Huynh 
> _______________________________________________ Kst mailing list Kst at kde.org https://mail.kde.org/mailman/listinfo/kst 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.kde.org/pipermail/kst/attachments/20101223/b08e9f46/attachment.htm 

More information about the Kst mailing list