[Kst] GSL + kst license clash

Barth Netterfield netterfield at astro.utoronto.ca
Thu Nov 1 12:22:25 CET 2007

GSLv3 is incompatible? With what?

GSL in kst is used by the plugins, which are pretty important, but 
not 'formally' required.

Can we 
	-change the plugins to gplv3?
	-'require' the pre v3 versions of GSL.  If someone chooses to compile w/ 
v3... shrug?
	-import a pre v3 version of GSL?

I would be interested if someone could point me to the issue.

On Thursday 01 November 2007 6:03:38 am Dirk Mueller wrote:
> Hi,
> It looks like the GNU Scientific Library switched over to GPLv3, which
> makes it incompatible with kst. Does anyone  have a suggestion on how to
> deal with that? Is the GSL dependency optional and can it be removed or
> replaced by another library that doesn't have that problem?
> Thanks,
> Dirk
> _______________________________________________
> Kst mailing list
> Kst at kde.org
> https://mail.kde.org/mailman/listinfo/kst

More information about the Kst mailing list