[Kst] piping into kst doesn't work when the data aren't immediately available (cvs)

George Staikos staikos at kde.org
Wed Aug 23 16:43:45 CEST 2006

On Friday 18 August 2006 12:49, Melchior FRANZ wrote:
> * George Staikos -- Friday 18 August 2006 18:44:
> >    Can you try some other tests like this?
> >
> > cat /tmp/xxxxx.txt | kst -y 1 -y 2 stdin
> >
> >    In general it seems to work for me.
> I've tried that and it worked. Did you not read the whole message?  :-}
> The problem was that piping didn't work because kst gave up quickly,
> while fgfs takes one or two minutes until it starts outputting anything.
> Now I have to work with the fifo, which allows me to start kst when
> fgfs is ready.

  I don't see any comment in your original message about trying it exactly 
like that.  I'll assume you did.  Can you prepare a simple testcase for us to 
reproduce the problem?

George Staikos
KDE Developer				http://www.kde.org/
Staikos Computing Services Inc.		http://www.staikos.net/

More information about the Kst mailing list