[Kst] KDE 3.3 - cant find X includes

George Staikos staikos at kde.org
Thu Mar 24 21:51:31 CET 2005

On Thursday 24 March 2005 15:15, Matthew D Truch wrote:
> > i'm trying to install KST under KDE 3.3 and i ran into an error that i
> > dont know what to do with. when i ran the ./configure, it got pretty far
> > through, but then i go this:
> >
> > checking for X... configure: error: Can't find X includes. Please check
> > your installation and add the correct paths!
> >
> > i did use --prefix=/opt to point to the kde install.  i didnt install kst
> > in /usr/local but in my home directory...i dont think that's the problem.
> >
> > anyway, any pointers would be much appreciated!  specifcally, where do i
> > change the paths to the X includes and how to i identify the path for the
> > X includes?
> Is it possible that you don't have the devel packages for X installed?
> For Suse, I believe the package is called xorg-x11-devel.
> $rpm -q xorg-x11-devel

   Yes, that should be the problem and installing it (xorg-x11-devel is the 
name) should be the solution.

George Staikos
KDE Developer				http://www.kde.org/
Staikos Computing Services Inc.		http://www.staikos.net/

More information about the Kst mailing list