[Kst] KDE 3.3 - cant find X includes

Matthew D Truch matt at truch.net
Thu Mar 24 21:15:16 CET 2005

> i'm trying to install KST under KDE 3.3 and i ran into an error that i 
> dont know what to do with. when i ran the ./configure, it got pretty far 
> through, but then i go this:
> checking for X... configure: error: Can't find X includes. Please check 
> your installation and add the correct paths!
> i did use --prefix=/opt to point to the kde install.  i didnt install kst 
> in /usr/local but in my home directory...i dont think that's the problem.
> anyway, any pointers would be much appreciated!  specifcally, where do i 
> change the paths to the X includes and how to i identify the path for the 
> X includes?

Is it possible that you don't have the devel packages for X installed?
For Suse, I believe the package is called xorg-x11-devel.  
$rpm -q xorg-x11-devel
should tell you if it's there.  Or if I'm wrong in the name, try
$rpm -qa |grep xorg
to see all the xorg packages you have installed.  Look for something
with devel in the name.  

If that's kosher, perhaps you just need to tell configure where Suse
put's it's X headers and libraries.  Use the --with-extra-includes
and/or --with-extra-libs directives to ./configure.  See 
./configure --help for all the options you can pass it.  

"In space, no one can hear you scream."
Matthew Truch
Department of Physics
Brown University
matt at truch.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mail.kde.org/pipermail/kst/attachments/20050324/1d0981be/attachment.pgp

More information about the Kst mailing list