[KPhotoAlbum] solved (or better: working) - Re: 3.1.1 crashes on reading in new photos

Martin Jost lists at majo.name
Wed May 28 21:08:35 BST 2008

Reimar Imhof schrieb:
> Hi Martin,
> I've build my own rpm on suse 10.2 64bit.
> But I didn't try suse 10.3...
> I took the original suse kphotoalbum-3.0....src.rpm.
I'm building from the tar.gz and install directly. I never tried to 
build a rpm so far.
The interesting part is, that it "just worked" for you. (See below for 
my experience)

Jan Kundrát schrieb:
> Martin Jost wrote:
>> I have 3.1.1 crashing on reading in new photos.
>> (see backtrace below)
>> This doesn't happen, if I move my photos taken in 2008 away, before 
>> starting KPA. (So one of these is triggering the bug, while the rest 
>> of 7881 photos don't trigger it - or just the fact, that it is 
>> parsing *new* photos, as opposed to the ones already seen by KPA)
> Hi Martin, sorry for late reply that is going to disappoint you :). 
> This indeed looks like a bug in the exiv2 library, but before talking 
> to upstream developers, I'd like you to verify if this happens in the 
> 4.0 trunk as well. If it does, I'd use a binary searching to find out 
> what image causes it to crash, and then work with this particular 
> image to see  if the bug is really in exiv2. The binary searching 
> works in the following way: you move half of your images away. If it 
> doesn't crash anymore, yo move the previously used images away, 
> restore the DB and move the previously omitted images back and 
> re-iterate. If it crashes, you move half of the current half images 
> away, and re-iterate.

I got it to work. First on my "old" (32 Bit) machine using the strategy 
I described. (This at least *was* necessary due to a too old version of 
exiv2 lib installed from rpm on this machine, which I can't update, due 
to a slow internet connection there)

Then I tried to fiddle once again with my new 64 bit machine. The 
"trick" was that easy: Just use the installed libs, instead of the ones 
I compiled myself (and installed under /pd/foto)

This version is "just working" as expected.
What I still don't get is, why my version using my self compiled libs 
didn't work.

I pointed the runtime search path to /pd/foto/libs using -R. (and 
checked with ldd, that the lib is really found there)
=> Still crashes

I removed the whole /pd/foto (and /pd/libs which might contain dependent 
libs) and compiled and installed from scratch
(using -R as before)
=> Still crashes

configure and compile, using the installed libs under /usr/lib(64)
=> Works

Best of all:
I installed libexiv2-0.15 in /pd/foto
This is the same version as installed using the Suse rpms:
 > rpm -q -a | grep exiv

But still it did crash.

Bottom line:
KPA is working again, but I don't have a clue, why I failed installing 
it during the first tries...


More information about the Kphotoalbum mailing list