[KimDaBa] new (and perhaps final) snapshot : Compile Error with libkipi

Rafael Beccar rafabeccar at speedy.com.ar
Sun Oct 3 18:22:50 BST 2004

El Dom 03 Oct 2004 13:54, Dominik Stadler escribió:
>So we are now at least three who have this compile problem, but nobody seems
>to know what is wrong here. I know nothing about autoconf/automake, so it's
>very hard for me to find out what is wrong. Any clues anybody?

Pretty funny! We both sent the messages almost at the same time.      :-)

As I said in the previous message, I think you will be able to compile 
flawlessly from CVS. There are some instructions here (in case you need 
them): http://ktown.kde.org/kimdaba/using-kimdaba-from-cvs.html


>One thing that I saw is that when I run automake, I get the following
> output:
># automake
>configure.in:71: required file `libkipi/libkipi.pc.in' not found
>because libkipi.pc.in is really in the main-directory, not under libkipi. Is
>that related to the problem somehow?
>Am Saturday, 2. October 2004 23:50 schrieb Reimar Imhof:
>> Hi Jesper, hi KimDaBa-users,
>> I've got a compile error with libkipi-2004-09-25.
>> I did a ./configure --prefix=/opt/kde3 like I used to do with every
>> snapshot / version. (Yes, I tried to compile libkipi after I compiled and
>> installed libkexif).
>> Thats my make output:
>> ##### Begin #######
>> ri at linux:~/compile/kimdaba-kde-32/2004-09-25/libkipi-2004-09-25-noi18n>
>> make make  all-recursive
>> make[1]: Entering directory
>> `/home/ri/compile/kimdaba-kde-32/2004-09-25/libkipi-2004-09-25-noi18n'
>> Making all in libkipi
>> make[2]: Entering directory
>> `/home/ri/compile/kimdaba-kde-32/2004-09-25/libkipi-2004-09-25-noi18n/libk
>>i pi' if /bin/sh ../libtool --silent --mode=compile g++ -DHAVE_CONFIG_H -I.
>> -I. -I.. -I../libkipi -I/opt/kde3/include -I/usr/lib/qt3/include
>> -I/usr/X11R6/include -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wnon-virtual-dtor
>> -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE
>> -Wcast-align -Wconversion
>> -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -O2
>> -Wformat-security -Wmissing-format-attribute -fno-exceptions
>> -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST
>> ".deps/interface.Tpo" -c -o interface.lo interface.cpp; \
>> then mv -f ".deps/interface.Tpo" ".deps/interface.Plo"; else rm -f
>> ".deps/interface.Tpo"; exit 1; fi
>> interface.cpp:215:25: interface.moc: No such file or directory
>> make[2]: *** [interface.lo] Fehler 1
>> make[2]: Leaving directory
>> `/home/ri/compile/kimdaba-kde-32/2004-09-25/libkipi-2004-09-25-noi18n/libk
>>i pi' make[1]: *** [all-recursive] Fehler 1
>> make[1]: Leaving directory
>> `/home/ri/compile/kimdaba-kde-32/2004-09-25/libkipi-2004-09-25-noi18n'
>> make: *** [all] Fehler 2
>> ###### End ######
>> I've got no idea why the interface.moc file wasn't created. I tried to
>> figure out the differences between this snapshot (2004-09-25) and the one
>> before (2004-09-11) but I didn't find any solution.
>> There's also another strange thing:
>> Configure complained about
>>  can't open ./libkipi/libkipi.pc.in: No such file or directory
>> But I think that problem doesn't cause the compile error.
>> (I've tried a second configure (from a new clean libkipi directory) with a
>> copy of libkipi.pc.in within the libkipi direkctory. That still gave the
>> compile error described above.)
>> Could you please tell me how to compile this libkipi snapshot?
>> I'm using kde 3.3.0-something and qt 3.3.3-something (the latest suse rpms
>> for suse 8.2).
>> Thanks a lot
>> Reimar
>> _______________________________________________
>> KimDaBa mailing list
>> KimDaBa at klaralvdalens-datakonsult.se
>> http://sulaco.hrhansen.dk/mailman/listinfo/kimdaba
>KimDaBa mailing list
>KimDaBa at klaralvdalens-datakonsult.se

More information about the Kphotoalbum mailing list