D13091: Small changes on the ViewManager related to simplification of the codebase
Kurt Hindenburg
noreply at phabricator.kde.org
Thu May 24 15:40:01 UTC 2018
hindenburg added a comment.
It is better to create patches that deal with one aspect, not file based. This allows for easier testing, review, git bisecting and reverting if necessary. This patch could be separated into 2 ones: the container patch and the view-> ones. Also we try to put whitepaces changes in a separate patch.
INLINE COMMENTS
> ViewManager.cpp:113
> ViewContainer *container = _viewSplitter->activeContainer();
> - if (container != nullptr) {
> - return container->activeView();
> - } else {
> - return nullptr;
> - }
> + return container ? container->activeView() : nullptr;
> }
While I agree the current code is ugly, I'm not fond of these ternary operator
REPOSITORY
R319 Konsole
REVISION DETAIL
https://phabricator.kde.org/D13091
To: tcanabrava, #konsole
Cc: hindenburg, konsole-devel, herrold, ngraham, maximilianocuria
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/konsole-devel/attachments/20180524/7094c24f/attachment.html>
More information about the konsole-devel
mailing list