[Konsole-devel] Review Request: Split class SessionManager into ProfileManager and SessionManager
Jekyll Wu
adaptee at gmail.com
Tue Mar 27 11:55:11 UTC 2012
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/104425/
-----------------------------------------------------------
Review request for Konsole.
Description
-------
The existing class SessionManager actually manages both profiles and sessions. Although sessions and profiles are closed related in concept, their corresponding code within existing SessionManager are mostly independent upon each other. Also, code like "SessionManager::instance()->defaultProfile()" is confusing at first sight.
The patch splits SessionManager into ProfileManager and SessionManager, each doing the job as its name implies.
Unlike previous split, this one involved new and more classes. I think it is better to be reviewd first.
Diffs
-----
src/Application.cpp 4925fa7
src/CMakeLists.txt d53fd4c
src/EditProfileDialog.cpp 58c6c21
src/MainWindow.cpp e7da18e
src/ManageProfilesDialog.cpp 0c5e083
src/Part.cpp 3051ab7
src/ProfileList.cpp bc95f49
src/ProfileManager.h PRE-CREATION
src/ProfileManager.cpp PRE-CREATION
src/SessionManager.h fe519dc
src/SessionManager.cpp bc9988f
src/ViewManager.cpp 52b62c0
Diff: http://git.reviewboard.kde.org/r/104425/diff/
Testing
-------
Tested with konsoleprofile, 'konsole --profile', etc. No regression observed so far.
Thanks,
Jekyll Wu
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/konsole-devel/attachments/20120327/0a1f10d7/attachment.html>
More information about the konsole-devel
mailing list