[Kmymoney] KMM - get online account update, some problems

Werner Dittmann Werner.Dittmann at t-online.de
Sat Sep 17 11:32:01 UTC 2011

Dear all,

I'm working with KMM 6.5 and current gwen* aq* libs (from opensuse) and
have problems to get online updates in KMM

History and setup:

until recently I used the iTAN method which worked flawlessly, both im KMM
and aqFinance. Now I needed to switch to HBCI with chipcard.

I got the chipcard and all necessary data to setup the account:
- DDV chipcard
- HBCI 2.20
- server names and addresses, etc

I used aqFinance to setup and it work fairly out-of-the-box and aqFinance
was able to get the current saldo of my account - haven't tested a bank
transfer (Überweisung) with aqFinance and chipcard yet. Thus, IMHO, the
basic setup for the chipcard works, card reader (Reiner e-com)
connection ok, etc.

Then I switched to KMM and tried to setup KMM.
I deleted the old online assigment and assigned the account to the
new online account and tried to update the account, that didn't work. The
main error message here was:

hh:mm:ss Antwort konnte nicht kodiert werden

Checking the mailing list I got the hint to check the user. Thus I called
Einstellungen -> aqbanking einrichten, select the "Benutzer" tab and checked
the user. It was all ok as far as I could see and then I tried the option
"Kontenliste abrufen" (get account list) and I got the following output in
the aqbanking window:
12:47:15 Connected.
12:47:15 There are no tan method descriptions (yet), trying One-Step TAN.
12:47:15 Aufträge werden kodiert
12:47:15 Antwort konnte nicht kodiert werden
12:47:15 Disconnecting from bank...
12:47:15 Disconnected.
12:47:15 AqHBCI abgeschlossen.
12:47:15 Vorgang abgeschlossen, Sie können das Fenster nun schließen.

I Already deleted the account and users and did a complete new setup but
only with aqFinance. Trying to create a new user with
Einstellungen -> aqbanking einrichten, select the "Benutzer" tab,
"Benutzer anlegen" didn't work. Selecting HBCI and "Chipkarte verwenden" during
the next steps lead to the following error:

"Error checking chip card(0).
 Maybe libchipcard or its plugins are not installed."

Taking the fact that aqFinance works with the chipcard that error message is
somewhat irritating. Of course aqFinance was not started when I tried the
setup with KMM.

As a guts feeling: maybe it is some leftover from the previous iTAN
setting? If yes: how to fix that? If no: what else could be the problem and how
to fix it? Would it help to completely delete the .aqbanking directory (after
saving the contents to some other place)? Some editing in .aqfinance or a KMM
configuration file required?

Best regards,

More information about the KMyMoney mailing list