KMM compiled from source this morning seems to broken

Brendan Coupe brendan at
Sun Jun 6 21:52:40 BST 2021

The differences in kmymoneyrc are not a problem.

I realized that my KMM file dropped in size from 2.1M to 606K some time
this morning. I assumed after I recompiled KMM.

I restored KMM to the older version (2021.05.31), opened the last good
file, made a change, saved it and the file size was about the same.

I restored KMM to the version compiled today (2021.06.06) and did the same
thing. The saved file went from 2.1M to 606K.

I repeated the process and the same thing happened. It appears that KMM is
damaging my file when I use the version compiled today.

*----Brendan Coupe*

On Sun, Jun 6, 2021 at 2:33 PM Brendan Coupe <brendan at> wrote:

> I'm still troubleshooting and not sure what is going on. KMM compiled from
> source about a week ago worked fine this morning. I compiled a fresh
> version and started getting errors. The initial error was asking me to
> select a currency, which in my case is USD. I did so but when I opened my
> file most accounts were zero with no transactions.
> I tried switching back to the previous good version but it asked the same
> question when I tried to open my file. I verified that my KMM file had not
> changed but kmymoneyrc appears to have changed. I have lots of backups
> (thank you syncthing) and will let you know if I figure any more out.
> *----Brendan Coupe*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the KMyMoney-devel mailing list