Encryption Nightmare - I can't turn it off

Thomas Baumgart thb at net-bembel.de
Fri Feb 8 08:06:11 GMT 2019


On Donnerstag, 7. Februar 2019 21:11:30 CET Brendan Coupe wrote:

> I solved my encryption problem so I wanted to explain how just in case
> anyone else is having a similar problem.
> This morning I saved a test file that was encrypted. When I tried to
> open it with KMM the error said the file was not recognized. Same
> problem that I described above.
> Then I tried starting KMM from the command line. I was asked to enter
> the password to unlock my file in the terminal. I did and the file
> opened. I closed the file and tried again and my system remembered the
> password. I am now able to run KMM from the program icon in my
> application launch bar without a problem until the next time i logout
> (or it times out).
> I knew I was close so I tried several ideas I found on Google. The one
> that worked is changing a line in ~/.gnupg/gpg-agent.conf from:
> pinentry-program /usr/bin/pinentry-curses
> to
> pinentry-program /usr/bin/pinentry-gtk

and since we are a Qt application, there is

	pinentry-program /usr/bin/pinentry-qt5


	pinentry-program /usr/bin/pinentry-qt4

for the folks still on KDE4.



Thomas Baumgart

https://www.signal.org/       Signal, the better WhatsApp
'Either toss the Windows out of your computer,
 or toss your computer out the window!' -- Richard Stallman
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 868 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kmymoney-devel/attachments/20190208/033c5cac/attachment.sig>

More information about the KMyMoney-devel mailing list