problem with investment accounts in git master

Jack ostroffjh at
Mon Jan 1 01:19:07 UTC 2018

I was trying to create a test kmy file to demonstrate some problems I  
am having, even after Thomas fixed the issue of creating incorrect  
payees when importing investment OFX statements, and discovered two  
additional issues, not actually related.

First, if you create a new investment account, and put an amount in the  
box for Opeining Balance, it uses that number as Add Shares (with value  
of 1), and does NOT let you set an Opening Balance for the Brokerage  
account.   Given that KMM does not allow cash in the actual investment  
account, I would say it is wrong to allow any Opening Balance for the  
investment account, since I doubt those shares will ever be what  
someone actually expects.  Related to this, I will try to come up with  
a better label for the box regarding the Brokerage Account, since I  
think it really needs to be explicit that KMM does not allow cash in an  
investment account, even though many real brokers do.

Second, once you create the investment account, if you add a  
transaction of type "Add Shares" as soon as you enter the Security  
Name, it offers to let you create the security.  If you go through that  
wizard, it returns you to the Add shares transaction, but Enter is not  
enabled, because it does not think the security exists yet.  If you  
then go to the Investment View, (you might have to cancel or save the  
add shares transaction first) it looks like the new security is there,  
but you can't really do anything with it, and if you go back to the  
ledger, it sometimes (it's not been completely consistent for me) asks  
if you want to save or cancel (but it's not clear to me at that point  
which transaction it's talking about.)

I have gotten as far as no transactions in the investment account, but  
the apparently identical security present three times in the Investment  

I have tried both Stock and Mutual Fund with the same result.

Also, when returning to the ledger after creating the security, either  
the Enter nor the Cancel icon are selectable, which doesn't make sense  
to me.

Am I doing something strange, or is there something funny going on here?


More information about the KMyMoney-devel mailing list