[Kmymoney-devel] odd backup error

Jack ostroffjh at sbcglobal.net
Sat Apr 18 20:44:38 UTC 2015

On 2015.04.18 09:11, Thomas Baumgart wrote:
> On Saturday 18 April 2015 08:37:48 Jack wrote:
> > On 2015.04.18 02:10, Thomas Baumgart wrote:
> > > On Thursday 16 April 2015 11:52:10 Jack wrote:

>>>> I just tried to backup my file and got an error about failure to  
>>>> mount the directory.  (Of course I didn't copy the exact  
>>>> wording....)  The only problem is that the directory is just a  
>>>> folder two levels below my home directory, and doesn't need  
>>>> mounting, and I did not check the box about needing mounting, and  
>>>> backup has worked fine for years.  This is the second time this  
>>>> has happened, and simply restarting KMM fixed the problem both  
>>>> times.  I have not otherwise noticed anything strange about files  
>>>> or partitions or mounts.  If it happens again, are there any  
>>>> specific things I can check to try and figure out the cause?
> > >
>>> That is strange. In case the mount option is unchecked, a simple  
>>> 'echo' replaces the mount command. This is just so that the next  
>>> step in the process can be triggered by the successful finish of a  
>>> command (mount or echo in this case). The scenario you describe  
>>> would happen, when the 'echo' command returns an exit code other  
>>> than 0 (why should it) or the KProcess exitStatus differs from  
>>> QProcess::NormalExit. I can't image why either of the two should  
>>> happen.
> >
>> I think that gave me the answer, but I won't have time to test until  
>> this evening.  For years, I only ran KMM started from the start menu  
>> or an icon.  Recently, however, I've left those methods to start the  
>> distro installed version, and have a git version installed in a  
>> different location which I have to start with a script, from command  
>> line.  I suspect if I close that console, then the echo will fail  
>> because KMMs stdout has gone away.
> >
> > I'll confirm this after I test later.
> That would be fine. In that case, we need to use a different command  
> or mechanism to solve the problem.

I can confirm this is the issue.  I had never noticed before, but if  
KMM is launched from command line, when you do a file/backup, it does  
echo a newline to the console.  If I put KMM in the background, it  
behaves the same.  However, if I then close the console from which I  
launched it, trying to do a backup gives a popup "Error mounting  

Would the easiest change be to 'echo > /dev/null' ?  You might also  
just use the "true" command, but I don't know if that is present on all  
OSs where KDE runs.


More information about the KMyMoney-devel mailing list