Latest version of kdelibs and koffice for testing of Krita

Mag. Leonhard Landrock 1977-Hamlet at
Sat Dec 12 00:00:14 CET 2009

Hi all!

I'm curious about the latest koffice and wanted to give the development version 
a try. Therefor I started with a fresh installation of KDE 4.

BTW: I am using Debian squeeze (still "testing") and made an user "kdebuild" 
for my tests.

I did "git clone git:// qt-kde" to 
get the latest Qt. I installed Qt to "/home/kdebuild/usr/local/Trolltech/Qt-

Next I used (part of) the instructions on to get kdesupport 
installed. After installation of missing libaries (e.g. Boost) this worked 

Now I tried to compile kdelibs but I get the following error:

kdebuild at veneto:~/kde/src/trunk/KDE/kdelibs$ cmakekde
-- Found Qt-Version 4.6.0 (using /home/kdebuild/usr/local/Trolltech/Qt-
-- Found X11: /usr/lib/
-- Building kdelibs...
-- Phonon Version: 4.3.80
-- Found the KDE4 kconfig_compiler preprocessor: 
-- Found automoc4: /home/kdebuild/kde/bin/automoc4
-- Strigi API needs 'signed char'
CMake Error at 
/usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:70 (MESSAGE):
Call Stack (most recent call first):
  cmake/modules/FindSoprano.cmake:204 (find_package_handle_standard_args)
  CMakeLists.txt:93 (find_package)

-- Configuring incomplete, errors occurred!
make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden.  

So cmake complains about a missing Soprano. But I have "libsoprano-dev" 
installed. Sadly I can't remember wether Qt also needed to know about soprano.  

I believe the koffice developers work with the latest KDE 4. So I hope you can 
give me a hint what might be wrong.

Thanks in advance,

PS: In the end it's krita I am intrested in at most.

More information about the kimageshop mailing list