Review Request 123643: Move away from Baloo::Term
Emmanuel Pescosta
emmanuelpescosta099 at gmail.com
Wed May 6 08:26:02 BST 2015
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/123643/#review79945
-----------------------------------------------------------
src/search/dolphinfacetswidget.cpp (lines 118 - 160)
<https://git.reviewboard.kde.org/r/123643/#comment54842>
QStringList terms;
if (...) {
...
terms << QString::fromLatin1("rating>=%1").arg(rating);
}
if (...) {
...
terms << QString::fromLatin1("modified>=%1").arg(date.toString(Qt::ISODate));
}
return terms.join(QStringLiteral(" AND "));
Makes in more readable and future-proof :)
src/search/dolphinfacetswidget.cpp (line 180)
<https://git.reviewboard.kde.org/r/123643/#comment54843>
split by " AND "?
src/search/dolphinfacetswidget.cpp (line 181)
<https://git.reviewboard.kde.org/r/123643/#comment54844>
if (subTerms.size() == 1)
src/search/dolphinfacetswidget.cpp (line 184)
<https://git.reviewboard.kde.org/r/123643/#comment54845>
Why colons after modified and rating?
The rating term is build without colons.
src/search/dolphinfacetswidget.cpp (line 210)
<https://git.reviewboard.kde.org/r/123643/#comment54846>
split by " AND "? + const
src/search/dolphinfacetswidget.cpp (lines 211 - 213)
<https://git.reviewboard.kde.org/r/123643/#comment54847>
not needed anymore
- Emmanuel Pescosta
On May 5, 2015, 4:36 p.m., Vishesh Handa wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/123643/
> -----------------------------------------------------------
>
> (Updated May 5, 2015, 4:36 p.m.)
>
>
> Review request for Dolphin.
>
>
> Repository: dolphin
>
>
> Description
> -------
>
> Baloo is set to become a framework and wants to only export the bare
> minimum number of classes as it will need to provide ABI + API
> guarentees forever. The Term class is now no longer exported. It can be
> added back again.
>
>
> Diffs
> -----
>
> src/search/dolphinsearchbox.cpp b67d1e6
> src/search/dolphinfacetswidget.h 03fb127
> src/search/dolphinfacetswidget.cpp b183eb8
>
> Diff: https://git.reviewboard.kde.org/r/123643/diff/
>
>
> Testing
> -------
>
> Searching seems to work.
>
>
> Thanks,
>
> Vishesh Handa
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.kde.org/mailman/private/kfm-devel/attachments/20150506/1b8262bf/attachment.htm>
More information about the kfm-devel
mailing list