Review Request 113957: Rename of "Recently Accessed" to "Recently Saved"

Richard llom richard.llom at gmail.com
Mon Nov 25 00:23:11 GMT 2013


Mit dem reviewboard komme ich irgendwie nicht klar oder liegt das an rekonq?

Daher versuchs ichs mal hier...


I actually avoid renaming the variables, because doing this is more error 
prone and might actually break things. For instance is this variable only 
used in dolphin or do other (like the file open dialog) use this, too?

Second reason is, I hope that in the not so distant future, this actually 
might get fixed and than redoing this all again would be kinda dumb, IMHO.

However, if you insist on this, I would go rather with a generic name for 
variable and type names, like "RecentGroup" or "RecentCategory" or ... ?

Frank Reininghaus wrote:
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/113957/#review44113
> -----------------------------------------------------------
> 
> 
> Thanks for the patch! Looks good, but there are more occurrences of
> "recently accessed" in variable and type names, which should also be
> changed to "recently saved" for consistency.
> 
>> grep ecent -r | grep ccess
> 
> src/panels/places/placesitemmodel.cpp:    QList<PlacesItem*>
> recentlyAccessedItems;
> src/panels/places/placesitemmodel.cpp:                case
> PlacesItem::RecentlyAccessedType: recentlyAccessedItems.append(item);
> break;
> src/panels/places/placesitemmodel.cpp:                case
> PlacesItem::RecentlyAccessedType: recentlyAccessedItems.append(item);
> break;
> src/panels/places/placesitemmodel.cpp:   
> items.append(recentlyAccessedItems);
> src/panels/places/placesitemmodel.cpp:                                    
>          item->groupType() == PlacesItem::RecentlyAccessedType) &&
> src/panels/places/placesitem.h:        RecentlyAccessedType,
> src/panels/places/placesitem.cpp:        case RecentlyAccessedType:
> setIcon("chronometer"); break;
> src/panels/places/placesitem.cpp:    case RecentlyAccessedType:
> setGroup(i18nc("@item", "Recently Saved")); break;
> src/panels/places/placesitem.cpp:            return RecentlyAccessedType;
> src/panels/places/placespanel.cpp:    if (group ==
> PlacesItem::SearchForType || group == PlacesItem::RecentlyAccessedType) {
> 
> - Frank Reininghaus
> 
> 
> On Nov. 19, 2013, 11:08 p.m., Richard llom wrote:
>> 
>> -----------------------------------------------------------
>> This is an automatically generated e-mail. To reply, visit:
>> http://git.reviewboard.kde.org/r/113957/
>> -----------------------------------------------------------
>> 
>> (Updated Nov. 19, 2013, 11:08 p.m.)
>> 
>> 
>> Review request for Dolphin and Frank Reininghaus.
>> 
>> 
>> Bugs: 304854
>>     http://bugs.kde.org/show_bug.cgi?id=304854
>> 
>> 
>> Repository: kde-baseapps
>> 
>> 
>> Description
>> -------
>> 
>> This is a diff for the dolphin places bar, which renames "Recently
>> Accessed" to "Recently Saved" in the naming and in the code comments - as
>> discussed in https://bugs.kde.org/show_bug.cgi?id=304854 .
>> 
>> 
>> Diffs
>> -----
>> 
>>   dolphin/src/panels/places/placesitem.cpp 41f22cc
>>   dolphin/src/panels/places/placesitemmodel.cpp 681479d
>> 
>> Diff: http://git.reviewboard.kde.org/r/113957/diff/
>> 
>> 
>> Testing
>> -------
>> 
>> No.
>> 
>> 
>> Thanks,
>> 
>> Richard llom





More information about the kfm-devel mailing list