kdevelop lock icon

Friedrich W. H. Kossebau kossebau at kde.org
Thu Dec 23 15:39:43 GMT 2021

Am Mittwoch, 22. Dezember 2021, 16:43:43 CET schrieb Lou Lipnickey:
> I am user of Kdevelop on fedora 34 and a longtime user of Kdevelop. With the
> most recent update using dnf, Kdevelop does not open .html files so that
> they can be edited. Other files tried, (.e.g. .js, .txt, sh) are editable
> There is a lock icon at the bottom left which only appears on .html files. I
> have checked file permissions and they are all highly permissive.
> And I have googled extensive kdevelop html lock, kdevelop lock icon, etc all
> without any meaningful hits.

Not sure exactly if this is your problem, but recently someone with a similar 
update history hit a similar problem, which could be solved this way:

Please check if you have some file
around. If so, remove it, this is a file for some old hack to register the 
default browser, using a custom MIME type. And which seems now to be preferred 
over other MIME type definitions of files with the extension ".html". But 
sadly lacks the information that HTML files are a subtype of plain text files, 
thus KDevelop does not try to load a text editor, but instead tries to load 
whatever KPart is chosen as preferred MIME type handler for 

Once you have removed that file, run
    update-mime-database ~/.local/share/mime
so the actual MIME database (generated from those files in mime/packages) used 
(indirectly) by KDevelop is up-to-date and has the normal definition of HTML 
files again, which also defines them as subclass of plain text.

You might need to restart KDevelop first though, perhaps some data is also 
cached in the runtime instance.

Did this solve your issue?


More information about the KDevelop mailing list