Why my installation of 5.2.3 won't parse the code -- a clue (was: Re: 5.2.4 impression)

rh kramer rhkramer at gmail.com
Thu May 9 17:35:46 BST 2019

Intentionally top posting -- sorry, but I think I'm sort of starting from
the beginning.

Still avoiding some details which I don't think are relevant to my current
problem -- well, actually, I alluded to most of those oddities in what I've
written here.

The problem is this:

When I hover the mouse over various entities in the file I'm looking at
(like an include for another file in the project), I get a message like:

"Problem in semantic analysis
<filename>.h file not found"

When I hover the mouse over other entities in the file (like standard C++
includes, or entities that are both defined and used in the file I'm
looking at, I get a more meaningful message like:

<path and filename>
Includes n, included by m
<a list of declarations>

or, for a variable defined in this file:

<variable name with modifiers, e.g. const variablename>
Decl: <filename>:<linenum> Show uses

If it is a method (or variable) declared in another file, I get (again) a
message like:

"Problem in semantic analysis
Use of undeclared identifer <identifier name>

Those other files are in the same project.  (Irrelevant to this problem,
but I'll mention that the project I'm working on (scintilla-scite) consists
of two code bases, but I've imported both of them into the same session in
kdevelop as two projects.)

So, I guess some parsing is occurring (sp?), and maybe the biggest problem
is that the parser (clang?) is not finding these other files.

>From some source, I found the suggestion to run KDEV_CLANG_DISPLAY_DIAGS=1
KDevelop.AppImage and then display the results. Ok, here is what I see at
the command line (the first time I ran that I also saw a popup over
kdevelop, let me see if I can find that again):

rhk at s31:/rhk03/chroot/scintilla-scite/Scintilla-SciTE/scintilla/gtk$
KDEV_CLANG_DISPLAY_DIAGS=1 /usr/local/KDevelop.AppImage
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-rhk'
MESA-LOADER: could not create udev device for fd 11
kdevplatform.util: Path::init: invalid/unsupported Path encountered:
kdevplatform.shell: Could not load plugin "KDevCMakeManager" , it reported
the error: "Unable to find a CMake executable. Is one installed on the
system?" Disabling the plugin now.
Connecting to deprecated signal
"applications.menu"  not found in  ("/etc/xdg/menus")

kdevelop.plugins.qthelp: qmake query returned error: ""
kdevplatform.shell: Could not load plugin "KDevCMakeManager" , it reported
the error: "Unable to find a CMake executable. Is one installed on the
system?" Disabling the plugin now.
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-rhk'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-rhk'
kdevelop.plugins.git: couldn't find the git root for
kdevplatform.shell: could not create mime-type "text/x-python3"
fatal error: 'ILexer.h' file not found
fatal error: 'Scintilla.h' file not found
... <lots more of these>

Ok, I  can't C&P from that popup (I guess that is true of most popups), and
that screen didn't pop up this time, but it was the "Configure Project
<projectname (or sessioname?)> KDevelop" screen that came up, and, the
first time it came up, it was mostly (or maybe even all) blank.  I've been
(maybe pretty much blindly) playing around with the settings on that
screen, but nothing I've done so far has seemed to help.

I'm fairly certain that the build system I'm using to build the project is
make (rather than cmake) because the command I use to build the project
(outside of kdevelop, so far) is make, not cmake.  (I use make clean to get
rid of stuff, and I would use make install except for some of the oddities
about my setup (e.g., because I compile in a chroot but run outside the
chroot, I have to move the executables to some different locations -- I
build in a chroot with a more up-to-date compiler (I need GGC 8) than what
is available on Debian Jessie, but that chroot doesn't support X, so to run
scite-scintilla I have to exit the chroot and move the executables to the
"normal" locations (/usr/bin) in the base Jessie system.  They work there.

Some of the settings I've experimented with on the "Configure Project
<projectname (or sessioname?)> KDevelop" include:

Build Configuration: <iirc, I've never gotten anything to appear here>

Build Directory:
/rhk03/chroot/scintilla-scite/Scintilla-SciTE/scintilla/gtk <current
setting -- this is the location of the scintilla code base (well, the
parent is at scintilla, but the make file for gtk is in this directory --
there is a makefile and a deps.mak file (among others) in this directory>
<note that this is the directory as specified when not running as/in the
chroot, which is how I run KDevelop (that is, not as/in the chroot.>

Build Tools

Action: Build

Enable: <checked>

Executable: /usr/bin/make <current setting>

Arguments: <blank>

Environment: Use default profile (currently: default)

I do have other obvious (to me) problems (for instance, when KDevelop
refers to the standard C++ include files, it finds those for GCC4, but (1)
I (think I) understand why (I think it is because kdevelop is operating
outside the chroot), and (2) (therefore) I'm not very worried about it for
now -- I'd like to get KDevelop to find the scintilla and scite files and
parse those, and maybe then I'll worry about the next problem(s).

On Thu, May 9, 2019 at 10:17 AM <rhkramer at gmail.com> wrote:

> Thanks to all who have replied.  I will respond to some emails here, then
> review the others to see if I should add addional replies from this
> machine
> (see the aside, below).
> (Aside: I'm replying from my main "everyday" machine on which I have a
> mail
> client installed, but it is not the machine on which I'm trying to run
> kdevelop (which, for various reasons does not have a mail client
> installed).
> It is much more convenient to send and receive email from this machine,
> but,
> later today, I will respond in more detail (by creating a text file and
> then
> pasting it iinto the gmail web client to send it (writing an email in the
> gmail webclient is a pain for me).)
> On Thursday, May 09, 2019 01:30:30 AM Kevin Funk wrote:
> > The Clang /compiler/ itself (as in the clang or clang++ executables) are
> > not required for KDevelop to run. You need to have libclang (the C
> > interface to Clang [1]) around at both build and runtime though.
> >
> > If you got KDevelop 5.2.x via the package manager, there's nothing else
> to
> > do. The package maintainers made sure the required dependencies for the
> > C++ Support are there.
> I have to correct one thing (in what I wrote) -- I actually have KDevelop
> 5.3.2. installed, and I did that via the KDevelop.AppImage package.
> I did look at the plugins and clang is listed there (with a checkmark,
> iirc).
> > Hope that helps. Please tell us what problems you're experiencing with
> > KDevelop right now, maybe we can help.
> Ok, I'll do that a little later, from the other machine.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop/attachments/20190509/8ecb45e0/attachment.html>

More information about the KDevelop mailing list