Unable to load plugins

Martin Fuhrer mfuhrer at gmail.com
Tue Feb 4 18:57:32 UTC 2014


We are deploying kdevelop 4.3.1 on Debian wheezy at my workplace and would
like to test out the plugins for valgrind, perforce, and cppcheck. For now
I'm installing the plugins into .kde in my home directory. Unfortunately
I'm not having any success getting the plugins to show up in kdevelop.

For the valgrind plugin, I'm building it as follows:

mfuhrer at cgy340ws[kdev-valgrind] 630===> cd build
mfuhrer at cgy340ws[build] 631===> cmake
-DCMAKE_INSTALL_PREFIX=/home/mfuhrer/.kde
-DCMAKE_PREFIX_PATH=/home/mfuhrer/.kde ..
[ snipped ... configures fine ]
mfuhrer at cgy340ws[build] 633===> make
[ snipped ... builds fine ]
mfuhrer at cgy340ws[build] 634===> make install
[  0%] Built target kdevvalgrind_automoc
[100%] Built target kdevvalgrind
Install the project...
-- Install configuration:
"RelWithDebInfo"

-- Installing: /home/mfuhrer/.kde/lib/kde4/kdevvalgrind.so
-- Set runtime path of "/home/mfuhrer/.kde/lib/kde4/kdevvalgrind.so" to
"/home/mfuhrer/.kde/lib"
-- Installing: /home/mfuhrer/.kde/share/kde4/services/kdevvalgrind.desktop
-- Installing: /home/mfuhrer/.kde/share/apps/kdevvalgrind/kdevvalgrind.rc

At this point, I run "kbuildsycoca4 --noincremental" and "ktraderclient
--servicetype KDevelop/Plugin".  The latter generates the following output:

---- Offer 1 ----
ktraderclient(11879)/kdecore (services) KServicePrivate::property: Request
for unknown property ' "UntranslatedGenericName" '
Invalid property UntranslatedGenericName
X-KDE-PluginInfo-Author : 'Harald Fernengel, Hamish Rodda'
X-KDE-PluginInfo-License : 'GPL'
X-KDE-PluginInfo-Name : 'kdevvalgrind'
X-KDevelop-Category : 'Global'
X-KDevelop-IRequired : 'org.kdevelop.IExecutePlugin'
X-KDevelop-Mode : 'GUI'
X-KDevelop-Version : '14'
Type : 'Service'
Name : 'Valgrind Support'
Comment : 'Valgrind is a tool that helps you find memory management
problems in programs. http://www.valgrind.org/'
GenericName : 'Debugger Frontend'
Icon : 'debugger'
Exec : 'blubb'
Terminal : 'FALSE'
Invalid property TerminalOptions
Invalid property Path
ServiceTypes : 'KDevelop/Plugin'
AllowAsDefault : 'TRUE'
InitialPreference : '1'
Library : 'kdevvalgrind'
DesktopEntryPath : 'kdevvalgrind.desktop'
DesktopEntryName : 'kdevvalgrind'
Keywords : ''
Categories : ''

Now I launch kdevelop and go to Settings > Configure KDevelop... and view
the Plugins panel. Neither valgrind, nor any of the other plugins I tried
installing, show up in the list. Any ideas how to load the plugins? Thanks!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop/attachments/20140204/055ce709/attachment.html>


More information about the KDevelop mailing list