Lastest Kdevelop doesn't insert output of external script

Jose Corona jcoronab at gmail.com
Wed Apr 17 23:13:10 UTC 2013


Thanks Millian....i have recompiled the lastest Kdevelop 4.5.60
(Downloaded via git today, together with new Kdevelop Platform and
Plugins, as referenced in
https://projects.kde.org/projects/extragear/kdevelop), my KDE is 4.8.4
(a Debian testing install) with  grantlee-0.3.0 and these are my
comments:

- Installed kdevplatform, kdevelop,  kdevelop-pg-qt....in that order:
no problems.
- Installed plugins are kdev-python, kdev-php, kdev-php-docs,
kdev-php-formatter, kdev-sql,  kdev-css, and kdev-xml in that order.
- My Kdevelop runs OK, plugins looks working OK as far as i could test
them with some python, ruby, .css, .xml and .php files
- External script insert data is now OK.

kdev-css, and kdev-xml: Got a lot of warnings when installing, but
looks  working OK.

Plugins with problems:

kdev-custom-buildsystem: Can not be installed with this version of kdevplatform.
kdev-ruby: compiles, but SIGUP Kdevelop at start with a certain ruby
file opened, so I uninstalled it (I want that fixed !).

Others plugins:

kdev-java, kdev-qmljs: Tried those last week, but got big problems
(sorry...but I forgot the exact details !)

I have not tested the remaining plugins.

----------

My wish is to have a better documentation plugin that allow:

- Multiple HTML links on the root menu of Documentation, not only for PHP.net
- Devhelp files configurable as before in Kdevelop 3.5
- QThelp files configurables as before/

May I suggest to unlink the plugins with problems from
https://projects.kde.org/projects/extragear/kdevelop....

Hope this help you....and THANKS a lot for help developing this
exceptional IDE  and remember to HAVE FUN !

Jose Corona
Dominican Republic.


On 4/14/13, Milian Wolff <mail at milianw.de> wrote:
> On Sunday 14 April 2013 22:47:46 Milian Wolff wrote:
>> On Tuesday 02 April 2013 18:11:59 Jose Corona wrote:
>> > I just downloaded and compiled lastest sources from
>> > git://anongit.kde.org/kdevelop (master branch, version 4.6...).
>> >
>> > Everything runs ok, except Kdevelop will not insert output of external
>> > script in the open document at cursor position (but the script runs, I
>> > know it because i can see the output if "Show Output" is marked).
>> >
>> > Just to let you know of this bug.
>>
>> Confirmed, please open a bug on bugs.kde.org.
>>
>> BTW: This is a regression introduced by the recent performance
>> optimizations
>> of the output model which is also used by the external script plugin...
>
> Fixed it now in master, please test.
> --
> Milian Wolff
> mail at milianw.de
> http://milianw.de



More information about the KDevelop mailing list