kvelelop + ifort

renato vacondio rvacondio at gmail.com
Fri Jan 11 18:04:46 UTC 2008


I'm quite new to kdevelop and I'm trying to use ifort compiler instead 
of gfortran,
I tried to follow the instruction reported at 
http://www.kdevelop.org/mediawiki/index.php/How_to_use_Intel_fortran_compiler
but it doesn't work.
My distro is Ubuntu 7.10 with kdevelop 3.5.0.

When I try to build the project the message is:

cd '/home/renato/Scrivania/lippo' && WANT_AUTOCONF_2_5="1" 
WANT_AUTOMAKE_1_6="1" make -f Makefile.cvs && cd 
'/home/renato/Scrivania/lippo' && F77=gfortran 
"/home/renato/Scrivania/lippo/configure" && cd 
'/home/renato/Scrivania/lippo' && WANT_AUTOCONF_2_5="1" 
WANT_AUTOMAKE_1_6="1" make -k
aclocal
autoheader
automake
src/Makefile.am: Fortran 77 source seen but `F77' is undefined
src/Makefile.am: The usual way to define `F77' is to add `AC_PROG_F77'
src/Makefile.am: to `configure.in' and run `autoconf' again.
make: *** [all] Error 1

I tried also with gfortran but the message is the same.

 From the konsole I can compile everything, so both gfortran an ifort 
are properly installed.
also automake and autoconfig are installed.

Thank you in advance for your help.

Renato




More information about the KDevelop mailing list