kdevelop & qt 4

Patrick Noffke pnoffke at bigpond.com
Sun Sep 4 10:10:09 BST 2005

You may need to put $QTDIR/bin in your path.  I use a script 
(kdevelop-qt-x11.sh) to run a particular version of QT.  It looks like this:

------------- begin script --------------------

export QTDIR=/opt/qt-x11-eval-3.3.4
export PATH=$QTDIR/bin:$PATH

kdevelop $@

------------- end script --------------------

Incidentally, I've tried to make KDevelop work with QT/Embedded using an 
autoconf project, and no luck (couldn't get it to run the right compiler 
with the right flags at the right times).  I had much better success 
with a QMake project.  Maybe you will too?

Hope this helps.


Imran Akbar wrote:

> I've now got the latest version of kdevelop (3.2.9) which should 
> support compilation with QT 4 directly through the ide (the qt tab on 
> the c++ settings in the project settings) - the problem is I've still 
> got QT 3 on my system and qmake defaults to using that version even 
> when i've tried setting the option for qt in kdevelop itself.  i've 
> set the environment variable for qtdir to the qt 4 directory, but i 
> think the problem would be solved if somehow i could get 'qmake' to 
> use the qt 4 version by default....
> any ideas?
> Thanks,
> Imran

to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«

More information about the KDevelop mailing list