32Bit development in 64Bit environment

Gunther Piez gpiez at web.de
Fri Jan 21 10:58:46 GMT 2005

Am Freitag, 21. Januar 2005 11:15 schrieb Reinhard Moeller:

> I transferred the project from a i32 platform to AMD 64, put CFLAGS into
> the make-options and tried to compile. This is what happens:
> cd '/home/rmoe/holz/holzl' && CFLAGS="-m32 -march=pentium"
> QTDIR="/usr/lib/qt3" gmake -k -j1 gmake: *** Keine Regel vorhanden, um das
> Target »/usr/lib/qt3/lib/libqt.prl«, benötigt von »Makefile«, zu erstellen.
> gmake: Konnte die »make«-Steuerdatei »Makefile« nicht neu erstellen.
> g++ -c -pipe -O2 -march=i586 -mcpu=i686 -fmessage-length=0 -Wall -Wall -W
> Any idea?

Some ideas.

-m32 is missing in the CFLAGS (this belongs in configure-options, not in make 
options) and
the 32 bit version of the qt library is not installed or is installed, but not 
used. this is called emul-linux-x86-qtlibs on my system, but i have never 
tried building against these. you probably need to explicitly specify the 
path for the linker.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop/attachments/20050121/d348deef/attachment.html>

More information about the KDevelop mailing list