kdDebug

Steven Suson suson at TuckerEnergy.com
Thu Feb 3 23:20:14 UTC 2005


Greetings once again,

    I just wanted to say that I've attempted to discover more 
information on this through the following means:

Google'd kde.org
Google'd kdevelop.org
Google'd the entire Internet

    None of these yielded any clues...

Needing help,
Steven Suson

Steven Suson wrote:

> Greetings,
>
>    Hopefully, this will not be too off topic (there is the possibility 
> that the problem I'm having is KDevelop specific). I am attempting to 
> use kdDebug, albeit unsuccessfully. Here's the code in question:
>
> kdDebug() << k_funcinfo << ": Sonde Type " << 
> toolItem->SCRData()->getSondeType() << " at depth " << item->depth() 
> << endl;
>
>
>    I stepped through this in the debugger to assure that it was being 
> executed, and in fact it is. My project is being compiled debug (i.e. 
> NDEBUG is not being defined by the compile command). Yet, I cannot 
> seem to get anything output. I've tried both running the program from 
> within KDevelop (where there is no output within the Application tab), 
> from within KDevelop's Konsole tab, and from a plain Konsole shell 
> prompt. None of these yield any output.
> Any clues as to how to get this working will be greatly appreciated.
>
>    I'm using KDevelop 3.1.2, KDE 3.3.1, Qt 3.3.3, gcc 3.2.2
>
> Thanks in advance,
> Steven Suson
>
> -
> to unsubscribe from this list send an email to 
> kdevelop-request at kdevelop.org with the following body:
> unsubscribe »your-email-address«
>

-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop mailing list