errror when compiling Gideon

Bernd Pol bernd.pol at online.de
Mon Sep 29 20:48:36 UTC 2003


Sorry, I nearly forgot the main thing. :-(

You can delete all <aronym> and </acronym> markups in the index.dobook file. 
They are of no viable importance. It is a simple xml text file. Just run Kate 
over it. Then it should work.

Concerning kdex.dtd and others, I dont't know what RedHat provided. But it 
obviously does not come after current standards what you have got. Perhaps 
you should ask in a kde-docbook mailing list again.
(see: http://www.kde.org/mailinglists/) 
It is their matter, actually.

Bernd

On Monday 29 September 2003 18:42, you wrote:
> Well, I've got the latest KDE available in RedHat (via up2date or
> apt-get/synaptic)...
> kdelibs is 3.1.12
> kdebase is 3.1.15
> kdeadmin, kdedesk  are 3.1.3
> Everything is 3.1.xx
>
> What am I to do ? Maybe there a way to regenerate these files system
> wide (sorry, but I'm quite a newbie there, and I don't know this at all)
> ?
>
> Thanks.
>
> Le lun 29/09/2003 à 10:33, Bernd Pol a écrit :
> > Hi,
> >
> > obviously you have got an outdated or broken kdex.dtd file and/or dtd
> > definition files connected to it. This is not easily remedied by just
> > replacing a single file only, as kdex.dtd etc. merely define changes of
> > the original docbook dtd definition files. The best way to fix that is to
> > update your KDE.
> >
> > Bernd
> >
> > On Sunday 28 September 2003 18:41, you wrote:
> > > Hi,
> > > I found the error signaled by the compiler output in
> > > /kdevelop/doc/kdevelop/index.docbook. XML validate launches the same
> > > message : "element acronym is not declared [...]"
> > >
> > > There's also 2 errors reported by XML validate in
> > > kdevelop/parts/appwizard/common/index.docbook line 12 "entity language"
> > > and line 3 "entity value & forbidden"
> > >
> > > There's also several errors reported about "chapter" and "listiem" in
> > > kdevelop/doc/kde_app_devel
> > >
> > > I have not the slightest idea if these messages come from my machine
> > > configuration or these documents themselves.
> > >
> > > My meinproc version is the same : 1.26.2.1 of 2002/12/05.
> > >
> > > I'll try updating from cvs later.
> > >
> > > Cheers.
> > >
> > > > this refers to the user manual documentation in the index.docbook
> > > > file. meinproc translates this into a series of html files.
> > > > I checked it again. No error messages here.
> > > > There are several possible sources of error. Most probably the
> > > > DocBook DTD definition file on your system is outdated. You may check
> > > > this in Kate (with the Kate XML Validation plugin activated): Load
> > > > index.docbook and select Tools->Validate XML.
> > > > If errors remain, could you please update the index.docbook file to
> > > > the latest version from CVS and try again.
> > > > If it still refuses to run, check the meinproc version. Mine is
> > > > 1.26.2.1 of 2002/12/05. Very old versions may not interpret some XML
> > > > commands correctly.
> > > >
> > > > There are a number of possible sites you may check for more info:
> > > > http://developer.kde.org/
> > > > http://i18n.kde.org/
> > > > http://scrollkeeper.sourceforge.net/docbook.shtml
> > >
> > > -
> > > to unsubscribe from this list send an email to
> > > kdevelop-request at kdevelop.org with the following body: unsubscribe
> > > »your-email-address«
> >
> > -
> > to unsubscribe from this list send an email to
> > kdevelop-request at kdevelop.org with the following body: unsubscribe
> > »your-email-address«
>
> -
> to unsubscribe from this list send an email to
> kdevelop-request at kdevelop.org with the following body: unsubscribe
> »your-email-address«


-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop mailing list