urgent question regarding qwt widget set

Ivica Bukvic ico at fuse.net
Thu Mar 14 04:46:37 GMT 2002

I apologize for the somewhat off-topic question, but I've been
struggling with this issue for the past week and am on top of that in a
rather big time crunch, so I would greatly appreciate any help I can get
on this one.

I am in a need of a graphing widget that is capable also of taking in
the input. I am also interested in developing strictly under qt. So,
naturally qwt widget (http://qwt.sf.net) was my choice. But, the problem
is as follows:

I've tried both 0.3.0 and 0.4.0 versions and both have the same problem.
I've tried them on RH 7.1, RH 7.2, and MDK 8.1 distros on different
machines using different hardware. I am using KDE desktop, so I even
tried different themes and styles thinking that could be the source of
the problem. All of these issues pretty much eliminate the possibility
that it is something to do with a particular distro or a hardware.

The only thing that was semi-constant on all three tested machines use
Qt 2.3.x (RH 7.1 x=0, while RH 7.2 and MDK 8.1 x=1).

Anyhow, the problem is that all examples compile flawlessly and qwtplot
looks just fine, but any other widget (i.e. radio buttons or sliders)
using those "tick marks" and values have those parts of the widgets
completely black! I have no clue as to what is the problem, but no
errors have been reported and the widgets do work, just that the "tick
marks" and their respective numbers do not show in all of the widgets
except for the QwtPlot which has these as a part of the widget.

I have no clue as to why is this happening, and I even tried
disto-specific RPM's with no success. I would greatly appreciate any
help I can get on this issue. Thank you very much! Sincerely,

Ivica Ico Bukvic, composer, multimedia sculptor, 
programmer, webmaster & computer consultant 
ico at fuse.net 
"To be is to do"   - Socrates
"To do is to be"   - Sartre
"Do be do be do"   - Sinatra
"I am"             - God

to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«

More information about the KDevelop mailing list