KDE/KDevelop under Solaris

Thamm, Russell russell.thamm at dsto.defence.gov.au
Mon Apr 30 07:06:14 UTC 2001


Roland,

I had all these variables set correctly except KDEDIR and INFOPATH.
I set KDEDIR. As far as I can tell INFOPATH is irrelevant, but I set
it to /usr/local/info

This made ABSOLUTELY NO difference.

However, I rebuilt KDE/KDevelop as root and that seemed to fix 
 "Unknown child process xxxx died" errors, but KDevelop still
displays the same problems.

1) Tooltips generally show as a black box. However, if I run KDevelop
   remotely (telnet session), tooltips always seem to work properly.

2) Still get the same errors creating a project.

3) The internal debugger WILL NOT run. It appears to come up but if I
   select run, step etc from the debug menu, nothing happens. I keep getting
   the following error (I'm not sure its relevant):

   "Konsole_grantpty: cannot determine the name of device.
    Kdevelop: chownpty failed for device /dev/ptyp0::/dev/ttyp0
      : This means the session can be eavesdropped.
      : Make sure konsole-grantpty is installed and setuid root."

    Since konsole_grantpty is installed (in /opt/kde/bin) and setuid root, I
find
    this message maddening.

    If I try to start the internal debugger a second time in a session, I
get the
    following error:

    "kio (kioslave): slavewrapper: Communication with app lost.
     Returning to slave pool."

I installed kdbg. Fortunatley this seems to run OK, so I have a workaround.

thanks
Russell Thamm

-----Original Message-----
From: Roland Krause [mailto:rokrau at yahoo.com]
Sent: Tuesday, April 24, 2001 12:00 AM
To: kdevelop at kdevelop.org
Subject: Re: KDE/KDevelop under Solaris


Russell,
I am running KDE-2.1.1 on Solaris 2.6 and I am running kdevelop-1.4cvs.
First, to get KDE to run on Solaris you have to set a few environment
variables, e.g. KDEDIR and QTDIR, LD_LIBRARY_PATH, MANPATH, INFOPATH
and PATH. Then most of your problems will go away. 
Email me at rokrau at yahoo.com and I'll share my startup scripts w/you.

Roland

--- "Thamm, Russell" <russell.thamm at dsto.defence.gov.au> wrote:
> Hi,
> 
> I just built and installed KDE 2.1.1 and KDevelop 1.4 under Solaris
> 2.6. 
> 
> Although everything seemed to build and install OK, I am noticing
> lots of
> little problems.
> 
> 1) Lots of display problems. In particular, the tooltips generally
> show up
> as black boxes.
>    Sometimes they work properly but there is no rhyme or reason to
> it. This
> is similar
>    to the problems that I noticed under kdevelop 1.0.
> 
> 2) Apparent bug in KDevelop Tool Menu - KDevelop fails to put a space
> between command 
>   and parameter (eg designer-client rather than designer -client)
> 
> 3) Errors (apparently non-fatal) creating a new project:
> 
>   a) make:*** [package-message] Error 1 (command make -f
> admin/Makefile.common package-messages)
>      - is this normal?
> 
>   b) kdoc: Can't read library
> /home/thammr/.kde/share/apps/kdevelop/KDE-Documentation/kdoc-
> reference/libkmid.kdoc.gz/libkmid.kdoc
>   - the gz file exists and was created by kdoc - so why this error?
> 
> 4) I get a large number of "Unknown child process XXXXX died"
> messages on
> startup - 
>    is this normal?
> 
> I know that this is slightly off topic, but can anyone tell me how to
> run
> KDE under Solaris? 
> 
> 1) I tried creating a .xinitrc with the command startkde.
> 2) Logged off and logged back on (selecting Open Windows instead of
> CDE)
> 3) I get a plain grey screen (nothing else)
> 
> Under CDE, I can start kdesktop, kicker and konquerer etc, so I think
> KDE is
> close to
> running. 
> 
> I have installed kdesupport, kdelibs, kdebase, kdevelop and kdoc from
> the
> 2.1.1 distribution
> on one of the KDE mirror sites. Do I need anything else?
> 
> thanks
> Russell Thamm
> 
> 
> 
> 
> -
> to unsubscribe from this list send an email to
> kdevelop-request at kdevelop.org with the following body:
> unsubscribe »your-email-address«

=====
--
Roland Krause
In the garage of life there are mechanics and 
there are drivers. Mechanics wanted!

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/

-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org
with the following body:
unsubscribe »your-email-address«

-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop mailing list