KDE/KDevelop under Solaris

Thamm, Russell russell.thamm at dsto.defence.gov.au
Mon Apr 30 05:55:26 UTC 2001


Walid,

Firstly, I can't get KDE itself to run. KDevelop runs but is very buggy.
So my advice is probably worthless.

I was surprised at how few problem I had building KDE/Kdevelop under
Solaris.

I am using gcc/g++ 2.95.2

I downloaded the Qt distribution from TrollTech. I had a problem compiling
anything that included the Xt header files. I modified the generated
Makefiles
and added the compiler option "-fpermissive" to get around this problem. I
specified
the platform solaris-g++ for configure. The other problem that I had with Qt
was the fact that the installation program gave the world no access to many 
library and executable files.

After installing Qt, I installed kdesupport, kdelibs, kdebase. These all
built
and installed without major problems although "make check" failed for the
last
two packages.

./configure --prefix=/opt/kde
gmake
gmake install


I kept getting lex errors when trying to build kdevelop. Eventually I
installed
flex and that solved the problem.

I had to update my version of perl to v 5.6. I also built and installed
kdoc.

I installed Qt non-locally, but I don't think you should have problems
installing
it locally. Just build it in your own directory and set QTDIR, path,
LD_LIBRARY_PATH
and MANPATH accordingly.

Russell Thamm


-----Original Message-----
From: Walid BACHA [mailto:bacha at gmx.net]
Sent: Monday, April 23, 2001 6:27 PM
To: kdevelop at kdevelop.org
Subject: Re: KDE/KDevelop under Solaris


Hi Russel,

actually I am using kdevlop under SuSE -Linux and I want to port a project
to Solaris/Sun for my
institute. Our System-Administrator isn't interested for KDE/Kdevelop. So I
have to do the port job on my
account. Could you give some hints about the c++compiler you are using under
Solaris and how to install
Qt locally (on my account not as root).

Thanks in Advance

Walid

"Thamm, Russell" schrieb:

> Hi,
>
> I just built and installed KDE 2.1.1 and KDevelop 1.4 under Solaris 2.6.
>
> Although everything seemed to build and install OK, I am noticing lots of
> little problems.
>
> 1) Lots of display problems. In particular, the tooltips generally show up
> as black boxes.
>    Sometimes they work properly but there is no rhyme or reason to it.
This
> is similar
>    to the problems that I noticed under kdevelop 1.0.
>
> 2) Apparent bug in KDevelop Tool Menu - KDevelop fails to put a space
> between command
>   and parameter (eg designer-client rather than designer -client)
>
> 3) Errors (apparently non-fatal) creating a new project:
>
>   a) make:*** [package-message] Error 1 (command make -f
> admin/Makefile.common package-messages)
>      - is this normal?
>
>   b) kdoc: Can't read library
> /home/thammr/.kde/share/apps/kdevelop/KDE-Documentation/kdoc-
> reference/libkmid.kdoc.gz/libkmid.kdoc
>   - the gz file exists and was created by kdoc - so why this error?
>
> 4) I get a large number of "Unknown child process XXXXX died" messages on
> startup -
>    is this normal?
>
> I know that this is slightly off topic, but can anyone tell me how to run
> KDE under Solaris?
>
> 1) I tried creating a .xinitrc with the command startkde.
> 2) Logged off and logged back on (selecting Open Windows instead of CDE)
> 3) I get a plain grey screen (nothing else)
>
> Under CDE, I can start kdesktop, kicker and konquerer etc, so I think KDE
is
> close to
> running.
>
> I have installed kdesupport, kdelibs, kdebase, kdevelop and kdoc from the
> 2.1.1 distribution
> on one of the KDE mirror sites. Do I need anything else?
>
> thanks
> Russell Thamm
>
> -
> to unsubscribe from this list send an email to
kdevelop-request at kdevelop.org with the following body:
> unsubscribe »your-email-address«


-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org
with the following body:
unsubscribe »your-email-address«

-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop mailing list