problems compiling under suse 7.0/qt 1.45 [was: Re: configure error: system fails at linking small kde app]

_Usul John Obscurant usul at
Sat Nov 25 18:29:22 GMT 2000

Ralf Nolden schrieb:
> _Usul John Obscurant wrote:
> >
> > hi,
> >
> > i was using kdk-1.2 under suse linux 6.2 i386 (kde 1.1.1, qt 1.44) and it
> > worked great!
> > but now i upgraded to suse 6.4 (kde 1.1.2, qt 1.45) recently. i cannot
> > recompile kdk-1.2 anymore - configure exits with the message:
> >
> > --
> > checking for KDE libraries installed... configure: error: your system
> > fails at linking a small KDE application!
> > Check, if your compiler is installed correctly and if you have used the same
> > compiler to compile Qt and kdelibs as you did use now
> > --
> >
> > after that i recompiled qt 1.45 and kdelibs 1.1.2 from the sources (rpms
> > included in suse 6.4) without problems, but kdk-configure does not work ...
> > any suggestions?
> >
> > thanks
> >         _usul
> Hi Usul,
> we´re mostly developing on SuSE, so this is not a problem of your system
> but probably because you´re missing the X headers. Installing package
> xdevel seems to be the valid solution though.

funny, that mail of mine was quite old ... i think i sent it about half a year
ago ...
but i was still having a very similar problem recently when installing suse
7.0 on my new computer - i hacked a bit into the configure script and found
out that it fails to compile a c++ file that includes some qt headers. suse
version of qt 1.45 did not have them in its includedir and when i looked at
trolltech i did not see anything of a qt 1.45, only 1.44.
i then downloaded trolltech's version, compiled it, set QTDIR and KDEDIR to
the correct paths and everything worked!
even though i had kde2 installed as primary wm and qt 2.2.2 as standard - so
the problems some people seem to have with compiling kdevelop under kde2/qt2
could be related to suse changing some header filenames!?
well, right now i am developing nice kde2 apps with kdevelop running in
kde2/HEAD (i have set KDEDIR to /opt/kde and KDEDIRS to /opt/kde2 and they are
not conflicting - i do not need any script for starting kdevelop!)

maybe this info might be useful for someone - for questions cc to usul at
directly as i do not look at the list very often.


to unsubscribe from this list send an email to kdevelop-request at with the following body:
unsubscribe »your-email-address«

More information about the KDevelop mailing list