kdevelop and SuSE6.1

Markus Gersting markus_gersting at gmx.de
Thu Mar 2 09:56:52 UTC 2000


Colin Green wrote:

> Hi,
>
> I am attempting to install kdevelop 1.1 on a SuSE 6.1 system.  I have
> tried using the suse packages supplied at wwwstud.uni-leipzig.de for
> suse 6.2:-
>
> c_cpp_reference-1.0-1.i586.rpm
> kdelibdocs-1.1-1.i586.rpm
> kdesgmltools-19990823-1.i586.rpm
> kdevelop-1.1-i586.rpm
>
> Is using the 6.2 packages the right thing to do here?
>
> All packages install OK except for kdevelop which generates the
> following output from rpm...
>
> ------------------------------------------
> # rpm -i kdevelop-1.1-1.i586.rpm
> failed dependencies:
>         libc.so.6(GLIBC_2.0) is needed by kdevelop-1.1-1
>         libc.so.6(GLIBC_2.1) is needed by kdevelop-1.1-1
>         libdl.so.2(GLIBC_2.0) is needed by kdevelop-1.1-1
>         libdl.so.2(GLIBC_2.1) is needed by kdevelop-1.1-1
>         libm.so.6(GLIBC_2.1) is needed by kdevelop-1.1-1
>         libstdc++-libc6.1-1.so.2 is needed by kdevelop-1.1-1
> -------------------------------------------
>
> OK so i've checked the source package for the first file(it already
> exists on my system) & rpm tells me it came from shlibs version 99.4.14.
> Does this need updating to a later version?
>
> Eventually I would like to learn about CVS, but I think packages are the
> best route for now while I try and pick up kdevelop (try and focus on
> one thing at a time!).
>
> Thanks,
>
> Colin D. Green

Hi Colin,

you use the suse 6.1 ?

the kernel-generation changed from 2.0.x to 2.2.x in 6.1
the lib changed ...
the hole distribution is ... well forget it !!!

The time I got 6.1: only problems, if I were you: change to suse 6.2 min.

Take the newest sources of  all failed and compile and install it
you need the kde-libs, kde-utils and so on before kdevelop can work

have a look in the readme, it will help!

good luck , markus gersting markus at gersting.de









More information about the KDevelop mailing list