Qt not found only when optimizing

OS owensavill at compuserve.com
Thu Jun 15 21:48:52 UTC 2000


There you go ! Yet another "cannot find Qt libs" problem and yet another
solution !

Is it about time this was sorted out ?! I've been hammering on about it since
kdevelop 0.something.

On Thu, 15 Jun 2000, you wrote:
> I'm developping an application since Kdevelop 1.0 and yesterday
> suddently I obtained a configure error, couldn't find Qt libs. It was
> the optimization flag. When I select to compile with optimization
> Kdevelop didn't find the libraries, didn't matter I exported QTDIR, nor
> I run configure with --with-qt-libraries=xxxx. Yes I had done a Make
> distclean.
> The most curious was that if I run Make -f Makefile.dist then
> ./configure the Qt libs were found fine (I can't compile because
> --fno-exception an -fno-rtti being passed to the compiler, I don't know
> why, this was the ISO/C++ and exceptions post below).
> _ONLY_ desactivating the optimization flag it compiled again.
> 
> 
> I'm running Kdevelop 1.2 version 20000608-A with the one-line patch
> (nothing to do with this) I posted to this list. I'm going to post it
> again rigth now.




More information about the KDevelop mailing list