Building KDevelop 2.0 from a snapshot

Richard Dale Richard_Dale at tipitina.demon.co.uk
Wed Jun 14 11:39:05 UTC 2000


I downloaded kdevelop20000610.tar. When the package is untar'd it doesn't
contain some of the files needed for autoconf and configure to work. But inside
the file 'Makefile.cvs' there are the following lines:

        @echo "This Makefile is only for the CVS repository"
        @echo "This se checkowill be deleted before making the distribution"
        @echo ""
        @if test ! -d admin; then \
           echo "Please recheckout this module!" ;\
           echo "for cvs: use checkout once and after that update again" ;\
           echo "for cvsup: checkout kde-common from cvsup and" ;\
           echo "   linheckouk kde-common/admin to ./admin" ;\
           exit 1 ;\
        fi                                                                                

I am wondering what the equivalent commands to build a snapshot which
hasn't got the CVS directory files in it?

I built KDevelop 2.0 by copying the admin directory, config.h.in from
the KDE 2.0 kdelibs, and copied the acinclude.m4 file from KDevelop 1.2. But it
didn't build the moc files at first because the new KDevelop (and KDE 2.0) use a
different macro for moc METASOURCES.  So I ran the command 'perl
./admin/am_edit ' which did the trick. I'm assuming that I'm missing a suitable
'acinclude.m4' or similar.   

ie KDevelop 2.0:
libkwrite_a_METASOURCES = AUTO 

ie KDevelop 1.2:
libkwrite_a_METASOURCES = USE_AUTOMOC   
        
When I ran KDevelop 2.0 it crashed - excellent, proper alpha-test behaviour! I
fixed a non-null terminated string list and then off it went ...and actually
started up. I opened an existing project - I now have an interesting 'opening
project' stack trace to look at, oh well...

-- Richard




More information about the KDevelop mailing list