Running executable

Thomas Matelich tmatelich at zetec.com
Fri Dec 15 16:05:58 UTC 2000


Werner Modenbach wrote:

> On Fre, 15 Dez 2000 John Birch wrote:
> > On Fri, 15 Dec 2000 21:29, Werner Modenbach wrote:
> > > On Don, 14 Dez 2000 Thomas Matelich wrote:
> > > > Could anyone tell me what I messed up this time?  When I hit F9, I get
> > > > /bin/sh: zac/zac: Not a directory.  This is almost a new project.  I
> > > > just created another project and running it works.  I looked for a
> > > > script that may be called for running the exe, but was unable to find
> > > > it.
> > >
> > > Fi Thomas,
> > >
> > > this seem to be a bug in kdevelop 1.3. I'v got the same problems here and
> > > I'm waiting for a patch. The problem only occures with terminal
> > > applications. I would like to install version 1.3 at out developer stations
> > > because the improvements are significant. Unfortunately we have a lot of
> > > terminal applications :(
> >
> > Cannot reproduce on my system with either terminal templates on kde1 or kde2.
> > I just do a simple new project;make;F9.
> >
> > Are these projects created with 1.3beta or 1.2 rather than 1.3release? If so,
> > try, make distclean;autoconf and automake;Configure;make;F9.
> >
> > Let us know what happens
>
> OK - I don't remember with which version the procect was created.
> Anyway I did exactly the steps you mentioned:
>        make distclean;autoconf and automake;Configure;make;F9.
>
> Here's the result coming up in the terminal window:
>
> ------------------------------------------------
> bash: cpm/cpm: Ist kein Verzeichnis
>
> Drücken Sie Eingabe um fortzufahren
> ------------------------------------------------
>
> Thats it :(

Well you all got away from me, durn time zones.  My problem is actually with a Qt2 MDI project.  The
changes I have made to it were to add a shared library, add some files to the main project and remove
some from it.  I don't know which of these changes caused the problem.  I have tried the new project
route and the new project works.  That is what makes me think it's in a script or Makefile somewhere.
The interesting thing is that I can debug my application, just not run it.  Hope that helps in any
further investigation.

Since this is not my major concern, I want to ask again about preventing my testing library from being
linked into my application (Mom always said the squeaky wheel gets the grease).  Should I write a sed
script for my Makefile to chop that out, or do have to start working in another project (please no)?
What if I made the library a custom project, would it still get linked into the app?

--
Thomas O Matelich
Senior Software Designer
Zetec, Inc.
sosedada at usa.net
tmatelich at zetec.com




-
to unsubscribe from this list send an email to kdevelop-request at kdevelop.org with the following body:
unsubscribe »your-email-address«



More information about the KDevelop mailing list