version of autoconf

W. Tasin tasin at
Tue Aug 22 17:26:37 UTC 2000

Werner Modenbach wrote:
> Hi !!!


> This morning I posted my probs with autoconf in my new kdevelop project.
> autoheader is telling me I have to have Autoconf version 2.13 or higher.
> Actually I have autoconf 2.13!

please check again the version of autoconf/automake by starting from the
console (under your account):
autoconf --version.
automake --version

I guess the path settings you have are still pointing to the old
automake/autoconf stuff.
(like conflicts between /usr and /usr/local)

BTW: In this case it's also a good idea to delete "config.cache" (of
your toplevel project dir), if you'd already started ./configure (with a
configure-script, which was created by the old autoconf... somehow)
> Now I downloaded and installed autoconf 2.14 and automake 1.4.
> Still autoheader in kdevelop reclaims for autoconf 2.13 or higher.
> Is there anybody who can help me? I really need to go ahead because I'm running
> a production system.
> I'm sure the problems have something to do with the project files
> because my older projects compile perfectly.

The older project do have an old acinclude.m4(.in).
We made the new project templates for compatibility reasons with KDE's
acinclude.m4 and for a better support of other distributions.

as you can see at this posting above, there is a flag 
which guarantees the usage of automake 1.4 and in this mess. you can
find the reason for the
AC_PREREQ([2.13]) inside acinclude.m4(.in)
> - Werner -
> --
> ---------------------------------------
> Werner Modenbach                 modenbach at
> ALC Computertechnik GmbH



  The KDevelop project: tasin at -
oohhh sveglia.... il mondo e' ammalato, ma x colpa di chi.........
:-------W. Tasin, FB
<Key-Fingerprint: 1610 835F 0080 32F4 6140  6CF7 A7D0 44CD 7961A645>

More information about the KDevelop mailing list