Problems when compiling latest snashots for KDE 1.1.x

MARK at GOLDEN-CHANNELS.CO.IL MARK at GOLDEN-CHANNELS.CO.IL
Wed Aug 9 11:35:14 UTC 2000


	/bin/sh ../libtool --mode=link g++  -O2 -fno-exceptions -fno-rtti
-fno-check-new -frtti  -s -o libkdlgloader.la -rpath /opt/kde/lib
-L/usr/X11R6/lib -L/opt/kde/lib  -no-undefined -version-info 1:0 -s
kdlgldr.lo kdlgldr_itemstuff.lo kdlgptrdb.lo -lkdeui -lkdecore -lXext -lqt
-lpng -lz -lm -lXext -lX11   -lXext  -lqt -lpng -lz -lm -lXext -lX11

Pay attention -lXext -lqt and so on are mentioned 4 times. Edit appropriate
command, remove duplicates and libtool will compile it OK.

Mark
> -----Original Message-----
> From:	Pascal Francq [SMTP:pfrancq at ulb.ac.be]
> Sent:	ו 04 אוגוסט 2000 16:01
> To:	kdevelop at kdevelop.org
> Subject:	Problems when compiling latest snashots for KDE 1.1.x
> 
> Hi,
> I try to compile the latest snashofts of KDevelop for KDE 1.1.x. I have
> these
> error messages:
> 
> libtool: link: warning: `-version-info' is ignored for programs
> g++ -O2 -fno-exceptions -fno-rtti -fno-check-new -frtti -s -o
> .libs/libkdlgloader.la.closure libkdlgloader_la_closure.o -s kdlgldr.o
> kdlgldr_itemstuff.o kdlgptrdb.o -L/usr/X11R6/lib -L/opt/kde/lib
> /opt/kde/lib/libkdeui.so /opt/kde/lib/libkdecore.so -lXext -lqt -lpng -lz
> -lm -lXext -lX11 -lXext -lqt -lpng -lz -lm -lXext -lX11  -Wl,--rpath
> -Wl,/opt/kde/lib
> creating libkdlgloader.la.closure
> /bin/sh ../libtool --mode=link g++  -O2 -fno-exceptions -fno-rtti
> -fno-check-new -frtti  -s -o libkdlgloader.la -rpath /opt/kde/lib
> -L/usr/X11R6/lib -L/opt/kde/lib  -no-undefined -version-info 1:0 -s
> kdlgldr.lo kdlgldr_itemstuff.lo kdlgptrdb.lo -lkdeui -lkdecore -lXext -lqt
> -lpng -lz -lm -lXext -lX11   -lXext  -lqt -lpng -lz -lm -lXext -lX11
> rm -fr .libs/libkdlgloader.la .libs/libkdlgloader.* .libs/libkdlgloader.*
> g++ -shared  kdlgldr.lo kdlgldr_itemstuff.lo kdlgptrdb.lo
> -L/usr/X11R6/lib -L/opt/kde/lib /opt/kde/lib/libkdeui.so
> /opt/kde/lib/libkdecore.so -lXext -lqt -lpng -lz -lm -lXext -lX11 -lXext
> -lqt -lpng -lz -lm -lXext -lX11 -lc  -Wl,-soname -Wl,libkdlgloader.so.1 -o
> .libs/libkdlgloader.so.1.0.0
> /usr/bin/ld: .libs/libkdlgloader.so.1.0.0: undefined versioned symbol name
> clog@@GLIBC_2.1
> /usr/bin/ld: failed to set dynamic section sizes: Bad value
> collect2: ld returned 1 exit status
> make[2]: *** [libkdlgloader.la] Error 1
> make[2]: Leaving directory `/usr/src/sources/DevTools/kdevelop/kdlgloader'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/src/sources/DevTools/kdevelop'
> make: *** [all-recursive-am] Error 2    
> 
> But, I can compile the snapshots of june and I have glibc-2.1.2-3
> installed
> (Caldera OpenLinux 2.4). So, what is going wrong?
> -- 
> 
> 
> Ir. Pascal Francq
> Researcher
> Universitי Libre de Bruxelles
> Faculty of Applied Mechanics
> Avenue F.D. Roosevelt, 50
> CP 165/41
> B-1050 Brussels
> BELGIUM
> Tel. +32-2-650 47 65
> Fax +32-2-650 27 10
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kdevelop/attachments/20000809/44a5c79b/attachment.html>


More information about the KDevelop mailing list