root vs. user

OS owensavill at compuserve.com
Fri Aug 4 20:31:58 UTC 2000


Hello,

I've just started working for a company that develops on Linux (hooray !).

Up until I arrived they used emacs, or vi, and command line egcs. Having been
there a few days it became apparent that some of the developers were missing
their Window$ IDE's, especially for browsing variables etc.. So when I said
IDE's were becoming available for Linux they jumped and said "well, lets see
some then" ! Of course being a 'long time' user of kdevelop I primarily
suggested using it.

However, imagine my embarrassment when kdevelop ran up as root, but just
crashed with a segmentation fault and a core dump when launched as a normal
user !!! (Their setup won't allow make's as root for a start.)

We are using Red Hat 6.2, with very little updates. I've tried your kdevelop
1.2-1, since Red Hat's 1.2-8 requires libraries I am not allowed to install (it
involves pulling in 'compat' libraries and switching over to gcc - which then
fails to compile !). Mandrake's 1.2-1mdk requires installation of their
libstdc++, which can be installed with Red Hat's libstdc++ (since none of the
files conflict !!!) but this has exactly the same problem.

Has any one seen this problem ? Any help would be appreciated. 

This problem does not occur on my Mandrake 7.1 system at home.

I've tried clearing out all the .kde/share/config/kdev* files but still the
same happens.

Is there a way I can got right back to the state after a fresh install ? I.e.
so it brings up the config dialog.

Thanks,
Owen




More information about the KDevelop mailing list