Weird kdevelop problems

W. Tasin tasin at e-technik.fh-muenchen.de
Mon Apr 10 14:11:55 UTC 2000


Sean Harmer wrote:
> 
> On Mon, 10 Apr 2000, you wrote:
> > On Mon, 10 Apr 2000, you wrote:
> > > so please try to compile/install and use an actual snapshot...
> > > it wouldn't be quite good, if we would port an error to version 1.2.
> > >
> 
> Just tried installing todays' snapshot of 1.2, and it gives the same errors as
> kdevelop 1.1. I tried using the Search in files dialog and this kicks up the
> error:
> 
> grep: /bin/grep: cannot execute binary file
> 
> in the konsole from which I am running kdevelop. It sounds like something has
> gotton screwed up on my system and kdevelop is having trouble executing
> commands, even though I can execute them manually from the command line.
> Weird heh?

KDevelop uses /bin/sh for it's processes...

IIRC some process-calls inside KDevelop were still /bin/bash... this was
an changement, we had to made.

So please try to do the following:

#/bin/sh -c 'perl --version'
or
#/bin/sh -c '/bin/grep --version'

Ciao 

Walter

> 
> Any more ideas?
> 
> Cheers,
> 
>         Sean
> 
>   Oh, and how is education supposed to make me feel smarter?
>   Everytime I learn something new, it pushes some old stuff
>   out of my head. Like that time I took the wine making
>   course and I forgot how to drive.
> 
>         - Homer J. Simpson

--
oohhh sveglia.... il mondo e' ammalato, ma x colpa di chi.........
(Zucchero)
:-------W. Tasin, FB 04,
FHM-------------------PGP-KeyID:0x7961A645----------:
<Key-Fingerprint: 1610 835F 0080 32F4 6140  6CF7 A7D0 44CD 7961A645>
<http://wwwkeys.pgp.net:11371/pks/lookup?op=index&search=0x7961A645&fingerprint=on>




More information about the KDevelop mailing list