Weird kdevelop problems

Sean Harmer sh at astro.keele.ac.uk
Mon Apr 10 08:30:40 UTC 2000


Hi All,

I am having a very strange set of problems with kdevelop. Until the middle of
last week I was using kdevelop 1.1 with no problems, (great program by the
way). Then, when I came to make the project I got a message in the output
window saying,

CXX FLAGS=":CXXFLAGS=":NO such file or directory 
*** failed ***

I also get this message if I try to use the configure option from within
kdevelop. When I try to create a new project of any type I get the following in
the error window of kappwizard,

perl: No such file or directory.
perl: No such file or directory.

And it stops there. Also, if I click on rebuild all, I get the following errors
reported,

gmake: /usr/bin/gmake: cannot execute binary file
*** failed ***
gmake: /usr/bin/gmake: cannot execute binary file
*** failed ***

Now for the weird bit - we still have an old kdevelop 1.0 installed elsewhere
on the system and this still works fine. I have tried blowing away all of my
kde installation and ~/.kde and reinstalling but I still get these errors. I
have also tried installing a kdevelop 1.2 daily snapshot with the same results.

I can still configure and make the projects that I have from the command line
or kdevelop 1.0.

Does anybody have any ideas what is going on and how to fix it?

Any help greatly appreciated,

	Sean Harmer

 
Oh, and how is education supposed to make me feel smarter?
Everytime I learn something new, it pushes some old stuff
out of my head. Like that time I took the wine making
course and I forgot how to drive.

 - Homer J. Simpson






More information about the KDevelop mailing list